tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Zapczynski <i...@quarterleaf.com>
Subject mappings not working with mod_webapp.so, Apache 1.3.23, Tomcat 4.0.3
Date Fri, 24 May 2002 12:33:54 GMT
Hello all,

I am unable to access my Tomcat web application via Apache.  When I try, I get a 404 error
and the Apache error log shows that it is
looking for the application under my document root.

I have:

Apache version 1.3.23
Tomcat 4.03
mod_webapp.so from jakarta-tomcat-connectors-4.0.2-01-src
Red Hat Linux 6.2

Using mod_webapp.so, I am able to get Apache to connect to Tomcat as I can see from the following
in the apache_log.<date>.txt log upon
Apache startup:

2002-05-23 14:57:30 [org.apache.catalina.connector.warp.WarpConnector] Connection from /127.0.0.1:3767
to /127.0.0.1:8008
2002-05-23 14:57:30 [org.apache.catalina.connector.warp.WarpConnector] Connection from /127.0.0.1:3768
to /127.0.0.1:8008
2002-05-23 14:57:30 [org.apache.catalina.connector.warp.WarpConnector] Connection from /127.0.0.1:3769
to /127.0.0.1:8008
2002-05-23 14:57:30 [org.apache.catalina.connector.warp.WarpConnector] Connection from /127.0.0.1:3770
to /127.0.0.1:8008
2002-05-23 14:57:30 [org.apache.catalina.connector.warp.WarpConnector] Connection from /127.0.0.1:3771
to /127.0.0.1:8008


After these messages, I also see several messages of the type:

2002-05-23 14:57:30 [org.apache.catalina.connector.warp.WarpConfigurationHandler] Filter mappings
(0)

I'm not sure if this is typical or part of my problem.

>From my httpd.conf:

LoadModule webapp_module libexec/mod_webapp.so

WebAppConnection conn      warp  localhost:8008
WebAppDeploy     myapp  conn  /myapp
WebAppInfo /webapp-info

"myapp" is named exactly as it exists in my /home/tomcat/webapps directory.  When I access
either http://host/myapp or
http://host/webapp-info, I receive a 404 error in the Apache access log and the error log
is looking for /usr/local/apache/htdocs/myapp.

Can anyone point out what I may be doing wrong?

Thanks in advance!

-Ian


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message