tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cst...@aias.gr>
Subject Re: Re: mod_jk: ajp13: cpu load problem with apache
Date Thu, 01 Jan 1970 00:00:00 GMT
First of all thank you for your interest.
I will download the latest code and try this out. I do have the debug mode 
enabled so I will sent you any errors (although I have not noticed anything 
special). 
I don't think though that I can reproduce the problem myself. 
About the gdb, I have no experience of how to attach to the process but I will 
do my best to find a colleague that does.
Thanks,
Costas
> 
> Can you try the CVS head, and see if it still happens ?
> If so, can you give us more details that would allow to
> reproduce it ? 
> 
> Messages like 'it doesn't work for me, you figure out why'
> are not very helpfull.
> 
> At least enable the debug messages, let it run until it
> hungs, then maybe trim the log and send the last entries.
> Or use gdb to attach to the problem process and do a 
> stack trace. 
> 
> Costin
> 
> On Wed, 1 May 2002, Costas Stergiou wrote:
> 
> > Hi,
> > I have an installation of Apache 1.3.19 + Tomcat 4.0.3
> > on a aix4.3 machine with IBM JDK 1.3.0. I have two tomcat
> > engines and I use the lb worker of mod_jk to balance user
> > request to these two engines. 
> > 
> > The problem is that some httpd processes seem to go
> > into some cpu performance tasks and start consuming all
> > the cpu of the machine (2processors, 2GB mem). After
> > some time almost all available CPU is consumed by the
> > apache processes. If I kill the child processes that cause
> > the problem, the load falls back to normal. At the same time,
> > I notice that I have excessive CPU usage in one of the
> > tomcat instances.
> > 
> > The problem keeps recurring all the time (almost every hour).
> > I read in the mail-archives about similar problems but I didn't 
> > find a good answer. 
> > 
> > The version of mod_jk is the one in jakarta-tomcat-connectors-4.0.2.01
> > I compiled the source on the same machine (aix).
> > 
> > I have to say that I have noticed similar problems on many more 
> > apache installations that have similar installations (apache, lb + 
> > 2 or more tomcat engines) with older versions of mod_jk and tomcat.
> > 
> > Actually, the above problem makes the lb worker unusable since 
> > I cannot trust the setup in my production environment. 
> > 
> > Please, any idea or patches or whatever will be very helpful.
> > Thanks very much for any ideas,
> > Costas
> > 
> > 
> > 
> > 
> 
> 
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> 
> 


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message