tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Wong" <steve_w...@macroview.com>
Subject RE: Use Worker MPM with mod_webapp
Date Thu, 23 May 2002 08:59:26 GMT

I got same case for Apache2.0.36.
I find that if I made every requests with 1 second interval, all requests can be finished.
However if I change it to about 100 ms, the request fails with the error_log stating the MaxClient
exceeds.
Do someone has tried tuning up Apache using worker MPM and successfully integrate with Tomcat
in Solaris Environment?

Thx. and Regards.
Steve.

-----Original Message-----
From: Nikola Milutinovic [mailto:Nikola.Milutinovic@ev.co.yu]
Sent: Thursday, May 23, 2002 1:54 PM
To: Tomcat Users List
Subject: Re: Use Worker MPM with mod_webapp


Does mod_webapp work well with Worker MPM??
I find no problem when I am using prefork MPM but return code to be 500 when I am using
worker MPM.
My config is Apache2.0.35, mod_webapp built from jakarta-tomcat-connector-src, jdk1.3.1, Solaris8.

----

OS: Tru64 UNIX 4.0D (Digital UNIX or DEC OSF/1)
Apache 2.0.36 worker MPM
mod_webapp from "jakarta-tomcat-connectors-4.0.2-01-src"
built using GCC 3.0

Working like a charm. With 2.0.35 I couldn't get a connection. Tomcat side would yell "Premature
end of header" and Apache would log "[crit] listener thread didn't exit". 2.0.36 works without
hickups.

Does anyone know what are "leader" and "threadpool" MPMs? They appear in ./configure, but
no docs.

Nix.

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message