tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Wong" <steve_w...@macroview.com>
Subject RE: Use Worker MPM with mod_webapp
Date Fri, 24 May 2002 04:20:50 GMT

Here is what I see in the error_log

[Fri May 24 12:18:08 2002] [notice] Apache/2.0.36 (Unix) configured -- resuming
normal operations
[Fri May 24 12:18:23 2002] [error] (null)
[Fri May 24 12:18:23 2002] [error] (null)
[Fri May 24 12:18:23 2002] [error]
[Fri May 24 12:19:36 2002] [error] Cannot shutdown "warpConnection"
[Fri May 24 12:19:36 2002] [error] Cannot close "warpConnection"
[Fri May 24 12:19:36 2002] [error] Communitcation interrupted
[Fri May 24 12:19:36 2002] [error] Communitcation interrupted
[Fri May 24 12:19:36 2002] [error] Communitcation interrupted
[Fri May 24 12:19:36 2002] [notice] child pid 1706 exit signal Segmentation faul
t (11)
[Fri May 24 12:19:38 2002] [error] (null)
[Fri May 24 12:19:38 2002] [error] (null)

-----Original Message-----
From: Steve Wong 
Sent: Friday, May 24, 2002 10:11 AM
To: Tomcat Users List
Subject: RE: Use Worker MPM with mod_webapp




The Cannot mix error is like this:

Finishing up
checking for APR compilation flags... configure: error: Cannot mix gcc and native cc

-----Original Message-----
From: Steve Wong 
Sent: Friday, May 24, 2002 10:08 AM
To: Tomcat Users List
Subject: RE: Use Worker MPM with mod_webapp



Before having the error_log for you to see.
It's really troublesome for me to make Apache and mod_webapp in Solaris8.
In Linux, it is really fine.

In solaris 8, I have Gnu's ld and gcc installed.  And I also have solaris's ld there.
Solaris's ld is in /usr/ccs/bin And Gnu's ld is in /usr/local/bin and /usr/local/sparc.../bin

I find that if I don't rename the directory /usr/local/sparc... to something else.
Everytime I make Apache, it uses Gnu's ld in /usr/local/sparc... no matter what my PATH is
set.
However, Apache is stilling made fine.

BUT, when I run ./configure --with-apxs=..... FOR mod_webapp
It says that I cannot mix the gcc and native cc.  AND the configuration failed.
The configuration success if I use Solaris's ld to make Apache.

Why will this happen and Is this normal??

Thx. and Regards.
Steve.

-----Original Message-----
From: Simon Stewart [mailto:sms@lateral.net]
Sent: Thursday, May 23, 2002 6:30 PM
To: Tomcat Users List
Subject: Re: Use Worker MPM with mod_webapp


On Thu, May 23, 2002 at 10:49:53AM +0800, Steve Wong wrote:
>
> 	Does mod_webapp work	well with Worker MPM??
> 	I find no problem when I am using prefork MPM but return code to be 500 =
> when I am using
> worker MPM.
> 	My config is Apache2.0.35, mod_webapp built from =
> jakarta-tomcat-connector-src, jdk1.3.1, Solaris8.

I use the worker mpm on Linux, as well as Apache 2 and mod_webapp. It
works for me.... What do the apache logs say?

Cheers,

Simon

-- 
If You Can't Live Without Me, Why Aren't You Dead?
    My Life Story.

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message