tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tulan W. Hu" <t...@lucent.com>
Subject Re: building mod_jk on solaris
Date Fri, 10 May 2002 14:59:03 GMT
download the jakarta-tomcat-connectors-*src from tomcat4.0 location
the newer version should have buildconf.sh not just for solaris.

----- Original Message -----
From: "Martin van den Bemt" <martin@isallineed.org>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Friday, May 10, 2002 10:56 AM
Subject: RE: building mod_jk on solaris


> This is some info of how I built it on solaris sparc boxes. It was using
> tomcat 33 though, and you have to change the directories accordingly.. Let
> me remind you that some of the things can actually already been fixed or
> working differently..
>
> <start-of-paste>
> cd to
> /usr/local/tomcat/native/mod_jk/apache1.3
> If this file is not executable do chmod +x build-solaris.sh
> vi build-solaris.sh
> change the APACHE_HOME and JAVA_HOME lines to the correct directory
> structure.
>
> Since we need DEAPI to build mod_jk, we also have to change the line after
> the line
> echo Building mod_jk
> $APXS ....
> Add -DEAPI as the first parameter. If you don't have a DEAPI apache
install,
> leave this one out.
>
> If your ld is not in your path, do vi /usr/local/apache/bin/apxs and
change
> the ld
> (the line reading my $CFG_LD_SHLIB = q(ld); to q(/usr/ccs/bin/ld);
>
> and now run ./build-solaris.sh
>
> It should be build ok ;)
> (check to see if /usr/local/apache/libexec/mod_jk.so is present).
>
> <end-of-paste>
>
>
> Mvgr,
> Martin
>
> > -----Original Message-----
> > From: Jeff Larsen [mailto:larsen@qec.com]
> > Sent: Friday, May 10, 2002 16:02
> > To: Tomcat Users List
> > Subject: Re: building mod_jk on solaris
> >
> >
> > apxs requires perl.  You must have perl installed prior to installation
> > of apache httpd in order for the apache install to correctly configure
> > apxs. Otherwise, I believe you are on the right track.
> >
> > Jeff
> >
> > ----- Original Message -----
> > From: "Peter Choe" <choepete@mindspring.com>
> > To: <tomcat-user@jakarta.apache.org>
> > Sent: Friday, May 10, 2002 7:52 AM
> > Subject: building mod_jk on solaris
> >
> >
> > > i am trying to build mod_jk for tomcat4.0.  the only mod_jk i found is
> > > actually in tomcat3.3 though.  so, i tried to compile it using the
> > > build-solaris.sh script and i get the following error:
> > >
> > > bash-2.03# ./build-solaris.sh
> > > Building mod_jk
> > > cc -DEAPI -DMOD_PERL -DUSE_EXPAT -O -G -Kpic -I/usr/apache/include
> > > -I../common -I/usr/java/include -I/usr/java/include/solaris
> > -DSOLARIS  -c
> > > ../common/jk_ajp12_worker.c
> > > apxs:Break: Command failed with rc=16711680
> > > Error with apxs
> > >
> > > does anyone know how i can fix this?


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message