tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohammed Omar" <...@harf.com>
Subject Re: Tomcat on Windows2000 as a service
Date Thu, 23 May 2002 13:31:52 GMT
Thanks for your help
I downloaded Jk_nt_service ,  it solved all problems.

Thanks

----- Original Message -----
From: "John Niven" <John.Niven@marcat.com>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Thursday, May 23, 2002 4:24 PM
Subject: RE: Tomcat on Windows2000 as a service


> > -----Original Message-----
> > From: Mohammed Omar [mailto:mog@harf.com]
> > Sent: 23 May 2002 13:55
> > To: Tomcat Users List
> > Subject: Re: Tomcat on Windows2000 as a service
> >
> >
> > Check your "%JAVA_HOME%\jre\bin\" directory - you may not
> > have a "classic"
> > > directory in it, you may have "hotspot" directory instead
> > (and I think
> > > there are other possibilities, instead of classic/hotspot?)
> >
> > My Answer :
> > ------------------
> > I have no hotspot nor classic directory in
> > %JAVA_HOME%\jre\bin\ , I have 2 folders called server and
> > client contains the jvm.dll ,  I used the server directory .
> >
>
> OK, I'm still on JDK1.2.2 - not used these but they sound right.  I
suspect
> "server" is the right one - anyone care to coment?
>
> >
> > If that doesn't work, I'd check that "CATALINA_HOME" and
> > "JAVA_HOME" are set
> > > correctly - from a command prompt
> >
> > My Answer :
> > ------------------
> > They are set correctly
>
> OK.
>
> >
> >
> > I found that %CATALINA_HOME%\logs\stderr.log is empty .
> > And the service is exist in the control panel , but can not
> > be started and give a message saying internal error upon
> > restarting it!!!
> >
> > Here it is my command again :
> >
> > C:\Tomcat\jakarta-tomcat-4.0.3\bin>tomcat.exe -install
> > ApacheTomcat "%JAVA_HOME% \jre\bin\client\jvm.dll"
>
> There seems to be a " " [space] between %JAVA_HOME% and \jre on the 2nd
> line...but I'm clutching at straws now.
>
> > -Djava.class.path="%CATALINA_HOME%\bin\bootstrap.jar;%J
> > AVA_HOME%\lib\tools.jar" -Dcatalina.home="%CATALINA_HOME%"
> > -xrs -start org.apach e.catalina.Bootstrap -params start
> > -stop org.apache.catalina.startup.Bootstrap - params stop
> > -out "%CATALINA_HOME%\logs\stderr.log" The service was
> > successfully installed.
>
> One final thing: if you can't get this to work from the command line
there's
> a product ("Service+", I think) that will automate the process - I've not
> used it, but it's been mentioned on this list.
>
> >
> >
> > Any idea
>
> Fast running out, I'm afraid!
>
> Good luck,
> John
>
>  --
> John Niven
> Please reply through mailing list
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message