tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Costas Stergiou" <cst...@aias.gr>
Subject Re: Apcahe's CPU goes to 100%
Date Fri, 24 May 2002 08:32:54 GMT
ok, just reposting an older message:

> > [helium]/#gdb httpd 24550
> > GNU gdb 5.0-aix43-010414
> > Copyright 2000 Free Software Foundation, Inc.
> > GDB is free software, covered by the GNU General Public License, and you
> are
> > welcome to change it and/or distribute copies of it under certain
> > conditions.
> > Type "show copying" to see the conditions.
> > There is absolutely no warranty for GDB.  Type "show warranty" for
> details.
> > This GDB was configured as "powerpc-ibm-aix4.3.3.0"...httpd: No such
file
> or
> > dir
> > ectory.
> >
> > //24550: No such file or directory.
> > Attaching to process 24550
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > (no debugging symbols found)...(no debugging symbols found)...
> > ---Type <return> to continue, or q <return> to quit---
> > [Switching to Thread 1]
> > 0x20070e9c in jk_tcp_socket_recvfull ()
> > (gdb) bt
> > #0  0x20070e9c in jk_tcp_socket_recvfull ()
> > #1  0x2006b700 in ajp_connection_tcp_get_message ()
> > #2  0x200694c0 in ajp_get_reply ()
> > #3  0x20069344 in ajp_service ()
> > #4  0x200744c8 in jk_handler ()
> > #5  0x10020900 in ap_invoke_handler ()
> > #6  0x10044c30 in process_request_internal ()
> > #7  0x10045db4 in ap_process_request ()
> > #8  0x10002a50 in child_main ()
> > #9  0x1000244c in make_child ()
> > #10 0x10002140 in perform_idle_server_maintenance ()
> > #11 0x10001aec in standalone_main ()
> > #12 0x10001390 in main ()
> > #13 0x100001dc in __start ()
> > (gdb) quit
> > A debugging session is active.
> > Do you still want to close the debugger?(y or n) y
> > Detaching from program: , process 24550
> >

If you take a look at the code, it is quite easy to guess what is
happening...
It is a while loop that continues indefinitely (since sockets are
non-blocking)...


----- Original Message -----
From: "Cammy Ng" <cammy@businetcomm.com>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Thursday, May 23, 2002 11:15 AM
Subject: Re: Apcahe's CPU goes to 100%


> Please Post it.
>
> Thanks
>
> ----- Original Message -----
> From: "David Cassidy" <dcassidy@nisports.com>
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Sent: Friday, May 24, 2002 12:58 AM
> Subject: Re: Apcahe's CPU goes to 100%
>
>
> > please post it !
> >
> > I have seen this with ajp12 (not using ajp13)
> >
> > D
> >
> > Costas Stergiou wrote:
> >
> > >I have exactly the same experience on this. Actually, If this
> > >problem is not solved you cannot use tomcat load-balancing features;
> > >thus you cannot setup a real production stable environment!!
> > >
> > >ajp12 does not have this problem though (I think because it does
> > >not keep open sockets).
> > >After some minor investigation on the problem, I think that the bug
> > >has to do with an infinite loop that the ajp goes in waiting for some
> > >data from tomcat whereas tomcat has nothing else to send.
> > >I have traced the exact method that this error occurs (a simple while
> > >loop) and I think it shouldn't be that hard for someone that knows
> > >the code to figure out a solution or a work around...but noone has
> > >responded... If someone is interested I can repost my mail where
> > >I even give a stack trace of the runaway process.
> > >
> > >Hope someone gives some time into this, it is a pitty having such
> > >a good software such as tomcat and not being able to use it in
> > >critical cases.
> > >Costas
> > >
> > >
> > >
> > >----- Original Message -----
> > >From: "Cammy Ng" <cammy@businetcomm.com>
> > >To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> > >Sent: Thursday, May 23, 2002 10:22 AM
> > >Subject: Re: Apcahe's CPU goes to 100%
> > >
> > >
> > >
> > >
> > >>I like Tomcat a lot personally, however, if I cannot get any solution
of
> > >>this problem, I think I need to start testing other commercial
software
> > >>
> > >>
> > >like
> > >
> > >
> > >>Jrun, etc. Since they have there own connector, it may solve this
> problem.
> > >>
> > >>
> > >.
> > >
> > >
> > >>I was spending 2 months and look over the internet everywhere,(all
news
> > >>group, all site talking apache, tomcat, mod_jk) and come up with no
> > >>solution. If anyone has solution or answer on this problem Please help
> and
> > >>post it so that all people can share it..
> > >>
> > >>Thanks
> > >>
> > >>----- Original Message -----
> > >>From: "Costas Stergiou" <csterg@aias.gr>
> > >>To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> > >>Sent: Thursday, May 23, 2002 11:56 PM
> > >>Subject: Re: Apcahe's CPU goes to 100%
> > >>
> > >>
> > >>
> > >>
> > >>>Many of use have posted this problem here but I see that nobody
> > >>>can come up with an answer...
> > >>>
> > >>>----- Original Message -----
> > >>>From: "Cammy Ng" <cammy@businetcomm.com>
> > >>>To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> > >>>Sent: Thursday, May 23, 2002 9:39 AM
> > >>>Subject: Re: Apcahe's CPU goes to 100%
> > >>>
> > >>>
> > >>>
> > >>>
> > >>>>Hi,
> > >>>>
> > >>>>I have this problem too, but no one seems to answer this problem,
I
> > >>>>
> > >>>>
> > >>>believe
> > >>>
> > >>>
> > >>>>it is the mod_jk connector problem. Hope someone will find the
> > >>>>
> > >>>>
> > >solution
> > >
> > >
> > >>>for
> > >>>
> > >>>
> > >>>>this.
> > >>>>
> > >>>>Thanks
> > >>>>Cammy
> > >>>>----- Original Message -----
> > >>>>From: "Rajesh Mishra" <RajeshM@Cal.InterraIT.COM>
> > >>>>To: <tomcat-user@jakarta.apache.org>
> > >>>>Sent: Wednesday, May 22, 2002 9:36 PM
> > >>>>Subject: Apcahe's CPU goes to 100%
> > >>>>
> > >>>>
> > >>>>
> > >>>>
> > >>>>>I'm using Apache1.3.12 and Tomcat3.2 for my application.After
stress
> > >>>>>
> > >>>>>
> > >>>>testing
> > >>>>
> > >>>>
> > >>>>>for 4 hours , CPU utilization of Apache.exe process goes to
100%.
As
> > >>>>>
> > >>>>>
> > >a
> > >
> > >
> > >>>>>result when I try to access the website , I'm getting timeouts.
But
> > >>>>>
> > >>>>>
> > >I
> > >
> > >
> > >>>>could
> > >>>>
> > >>>>
> > >>>>>still access the website with tomcat port.
> > >>>>>
> > >>>>>Has anyone experienced this problem .I'm using mod_jk for this
> > >>>>>
> > >>>>>
> > >purpose
> > >
> > >
> > >>>>>Regards
> > >>>>>Rajesh
> > >>>>>
> > >>>>>--
> > >>>>>To unsubscribe, e-mail:
> > >>>>>
> > >>>>>
> > >>>><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > >>>>
> > >>>>
> > >>>>>For additional commands, e-mail:
> > >>>>>
> > >>>>>
> > >>>><mailto:tomcat-user-help@jakarta.apache.org>
> > >>>>
> > >>>>
> > >>>>--
> > >>>>To unsubscribe, e-mail:
> > >>>>
> > >>>>
> > >>><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > >>>
> > >>>
> > >>>>For additional commands, e-mail:
> > >>>>
> > >>>>
> > >>><mailto:tomcat-user-help@jakarta.apache.org>
> > >>>
> > >>>
> > >>>--
> > >>>To unsubscribe, e-mail:
> > >>>
> > >>>
> > >><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > >>
> > >>
> > >>>For additional commands, e-mail:
> > >>>
> > >>>
> > >><mailto:tomcat-user-help@jakarta.apache.org>
> > >>
> > >>
> > >>--
> > >>To unsubscribe, e-mail:
> > >>
> > >>
> > ><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > >
> > >
> > >>For additional commands, e-mail:
> > >>
> > >>
> > ><mailto:tomcat-user-help@jakarta.apache.org>
> > >
> > >
> > >
> > >
> > >--
> > >To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > >For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> > >
> > >
> > >
> >
> >
> >
> > --
> > To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> >
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message