tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian" <athi...@charter.net>
Subject Re: I'm getting no responses to my requests for help on this list
Date Thu, 16 May 2002 19:17:37 GMT
Here's what I would do , granted I don`t have much windows experience but a
couple things I `d try.  If you can see the servlets, it may not be a port
problem. Are you running through an http server such as apache ?
    I would think just maybe you have the runtime engine set as JAVA_HOME
not the JSDK. The best way to approach is one change at a time.

1) Is it running as a service ? If so disable that so you can start and stop
it yourself.
 2) With tomcat stopped, does anything display on http://localhost:8080 ?
3) Change TOMCAT_HOME to CATALINA_HOME (may solve ), CATALINA_HOME should be
the base installation directory (example c:\tomcat )
4) make sure JAVA_HOME is set to java base dir (C:\j2sdk1.4.0-rc)
5) does it work ?
6) C:\tomcat\bin\shutdown.bat  ( if not)
7) Open Server.xml in a text editor,
look for:

   <!-- Define a non-SSL HTTP/1.1 Connector on port 8080 -->
    <Connector className="org.apache.catalina.connector.http.HttpConnector"
               port="8080" minProcessors="5" maxProcessors="75"
               enableLookups="true" redirectPort="8443"
               acceptCount="10" debug="0" connectionTimeout="60000"/>
    <!-- Note : To disable connection timeouts, set connectionTimeout value
     to -1 -->
Change the port to say 9090

8) C:\tomcat\bin\startup.bat
9) try http://localhost:9090 or http://127.0.0.1:9090

10) Write me back with errors.




----- Original Message -----
From: Gary Frick <gjfrick@hotmail.com>
To: Tomcat Users List <tomcat-user@jakarta.apache.org>
Sent: Thursday, May 16, 2002 2:42 PM
Subject: Re: I'm getting no responses to my requests for help on this list


> Adrian,
>
>    I'm currently running on XP Professional using JSDK 1.4.0, JRTE 1.4.0
and
> Tomcat 4.0.3.  Is this what you are requesting?  Please excuse me, but I'm
> new to Tomcat and JAVA.
>
> Thanks,
> Gary
> ----- Original Message -----
> From: "Adrian" <athiele@charter.net>
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Sent: Thursday, May 16, 2002 2:46 PM
> Subject: Re: I'm getting no responses to my requests for help on this list
>
>
> >
> > Although , a good description of the error output , what about platform
,
> > JVM maker and version etc...
> >
> >
> > ----- Original Message -----
> > From: Gary Frick <gjfrick@hotmail.com>
> > To: <tomcat-user@jakarta.apache.org>
> > Sent: Thursday, May 16, 2002 10:30 AM
> > Subject: I'm getting no responses to my requests for help on this list
> >
> >
> > Hi All,
> >
> >    I've been working day and night trying to get Tomcat started and to
get
> > past the HTTP 500 error when trying to invoke the JSP examples.  I've
been
> > combing the archives, but I'm not seeing any real solutions.  What must
I
> do
> > and where must I go to get help?
> >
> >    First it would be helpful to know what is going on.  When I try to
> start
> > Tomcat I get the following (See below. Only providing first few lines of
> > trace).  When I try //localhost/examples  I can execute the servlets,
but
> > not the JSPs.  On the JSPs I always get HTTP Status 500 messages.  I've
> > followed the recommendations to recheck the classpaths and environment
> > variables (JAVA_HOME and TOMCAT_HOME), but this hasn't helped.  For one
> > thing I don't understand why port 8080 is already in use.  How can I
> check?
> >
> > Thanks,
> > Gary
> >
> > Catalina.start: LifecycleException:  null.open:  java.net.BindException:
> > Address
> >  already in use: JVM_Bind:8080
> > LifecycleException:  null.open:  java.net.BindException: Address already
> in
> > use:
> >  JVM_Bind:8080
> >         at
> > org.apache.catalina.connector.http.HttpConnector.initialize(HttpConne
> > ctor.java:1130)
> >         at
> > org.apache.catalina.core.StandardService.initialize(StandardService.j
> > ava:454)
> >         at
> > org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
> > a:553)
> >         at org.apache.catalina.startup.Catalina.start(Catalina.java:780)
> >         at
org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
> >         at
org.apache.catalina.startup.Catalina.process(Catalina.java:179)
> >         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >         at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> >         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
Source)
> >         at java.lang.reflect.Method.invoke(Unknown Source)
> >         at
org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)
> > ----- Root Cause -----
> > java.net.BindException: Address already in use: JVM_Bind:8080
> >         at
> > org.apache.catalina.connector.http.HttpConnector.open(HttpConnector.j
> > ava:950)
> >
> >
> >
> >
> > --
> > To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> >
> >
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>
>



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message