tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Li" <si...@budgettarget.com>
Subject apache+tomcat4.0.1+mod_webapp on RH6.2
Date Thu, 23 May 2002 19:27:13 GMT
Dear all,

I originally have a RH7.2 system, ran apache+tomcat4.0.1+mod_webapp without
problem. Now, my system need a migration, and unluckily, the `new` system is
RH6.2

I built my own mod_webapp.so and my apache (installed by rpms:
apache-devel-1.3.12-2 and apache-1.3.14-2.6.2) cannot load the mod_webapp.so
and complaints:

[root@budgettarget apache-1.3]# /etc/init.d/httpd restart
Shutting down http:                                        [FAILED]
Starting httpd: Syntax error on line 253 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/mod_webapp.so into server:
/etc/httpd/modules/mod_webapp.so: undefined symbol: pthread_sigmask
                                                           [FAILED]

I do:
[root@mydomain /root]# rpm -qf /lib/libc.so.6
glibc-2.1.3-23

What should i do, should i upgrade my glibc? or self-compile my mod_webapp?
Please help.

Best regards,
Simon.
======================


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message