tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph Molnar" <>
Subject Question re: Tomcat 4.0.3 (LE) and JDK 1.4
Date Wed, 03 Apr 2002 06:53:28 GMT
I have a question regarding the Tomcat 4.0.3 LE package that was put out (by
Apache) specifically for JDK 1.4.  This version purposely does not contain
things like JavaMail, an XML parser, etc.

In some cases they are missing because JDK 1.4 comes with the feature (an
xml parser, regexp)...others can be easily added (like JavaMail and the
Activation Framework). I am curious, however, about the JTA package. It is
missing, and yes, you can download one from Sun, however I noticed a few

a) the non LE 4.0.3 Tomcat has a JTA that is actually a bit different
(bigger) than the one that you can download from Sun
b) JDK 1.4 contains a few of the classes that make up the JTA package, but
not all of them

What is the recommended approach here if you are looking to use JTA?


Joseph Molnar

To unsubscribe:   <>
For additional commands: <>
Troubles with the list: <>

View raw message