tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zachary Kuhn" <zk...@pricegrabber.com>
Subject RE: getRemoteUser(), getAuthType() returning empty string instead of NULL?
Date Wed, 24 Apr 2002 19:42:05 GMT
I've looked through the archives, no luck. Here is the problem. After
installing the JBoss-2.4.4_Tomcat-4.0.1 package install, the tomcat server
throws the following exception. When i go to http://www.cscoders.com:8080/.
[INFO,EmbeddedCatalinaServiceSX] StandardHost[localhost]: MAPPING
configuration error for request URI
[ERROR,EmbeddedCatalinaServiceSX] HttpProcessor[8080][4] process.invoke
java.lang.NullPointerException
        at
org.apache.catalina.valves.ErrorDispatcherValve.status(ErrorDispatcherValve.
java:280)
        at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.
java:180)
        at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:5
64)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:170
)
        at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:5
64)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472)
        at
org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
:163)
        at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:5
66)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472)
        at
org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)
        at
org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:
1011)
        at
org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1106
)
        at java.lang.Thread.run(Thread.java:484)
I have the following env vars set up
CATALINA_HOME=/var/java/JBoss-2.4.4_Tomcat-4.0.1/catalina
CLASSPATH=/usr/java/jdk1.3.1_01:/usr/java/jdk1.3.1_01/lib/tools.jar:./
JAVA_HOME=/usr/java/jdk1.3.1_01
JBOSS_DIST=/var/java/JBoss-2.4.4_Tomcat-4.0.1/jboss
JDK_HOME=/usr/java/jdk1.3.1_01

in apache httpd conf i have
LoadModule webapp_module       modules/mod_webapp.so


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message