tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sefton, Adam" <Adam.Sef...@plc.cwplc.com>
Subject Tomcat4.0 + Apache2.0 integration on Win2K
Date Mon, 29 Apr 2002 17:48:14 GMT
Hi there,

I'm still having problems getting Apache to start with the mod_webapp module to connect it
to tomcat on Win2k.

I've installed mod_webapp as directed, and also put libapr.dll in system32 (also I've put
it in the /modules directory and I noticed that /bin directory already contains this dll)
and I've added the following lines to to httpd.conf:

LoadModule webapp_module modules\mod_webapp.so

WebAppConnection warpConnection warp localhost:8008
WebAppDeploy examples warpConnection /examples/

Whatever happens, I get the following error when I run apache -t from the command line:

Syntax error on line 178 of D:/apache/Apache2/conf/httpd.conf:
Cannot load D:/apache/Apache2/modules/mod_webapp.so into server: The specified module could
not be found.

I've tried explicitly naming the entire path in httpd.conf, I've also tried replacing the
"\" in the path with both "\\" and "/". 
My original install had spaces in the install path (apache group for example) so I've reinstalled
it to the directory path above.

The module is definately there.

Does anyone have any idea why it won't find the module? One thing to note is that I am running
Win2k professional, not server (this is meant to be a proof of concept project, but since
I can't even get tomcat and apache running together, its not going so well).

Any ideas? If anyone can help at all, then I would really appriciate it - this has been driving
me nuts for days :-)

Thanks all


Adam Sefton


**********************************************************************
This message may contain information which is confidential or privileged.
If you are not the intended recipient, please advise the sender immediately
by reply e-mail and delete this message and any attachments
without retaining a copy.  

**********************************************************************


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message