tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jay Gardner" <...@qwest.net>
Subject RE: Problem building mod_webapp.so for Solaris 8
Date Mon, 08 Apr 2002 16:02:50 GMT
You can find the bin at

http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0/bin/

I believe that the connector is the same for all 4.X versions. Also, make
sure you use the right .so. If you are using -EAPI, then use the
mod_webapp.so that is found in the eapi dir.

This is my installation using DSO:

1. Copy mod_webapp.so to the $APACHE_HOME/libexec/ dir.

2. Add the following to $APACHE_HOME/conf/httpd.conf

	Put this at the end of the load module section,

LoadModule webapp_module      libexec/mod_webapp.so



	Put this at the end of the add module section,

AddModule mod_webapp.c


Finally, put this either at the end of the file(to apply to entire server)
or within specific virtual host entries (for that host only),

<If Module mod_webapp.c>
 WebAppConnection conn      warp  localhost:8008
 WebAppDeploy     smartjobs    conn  /smartjobs
 WebAppInfo /webapp-info
</IfModule>

	Note - In this case, /smartjobs is a tomcat webapp. Just add more contexts
here as you create them in tomcat.

3.

	Finally, it is import to stop and start each server. The order of doing
this is important.

First stop both tomcat and apache.

	Start tomcat

	Start apache  - Some people say that they have to wait up to 10 second
before they start apache so that things work correctly.


I hope that this will help you!

--Jay Gardner



	Start apache
-----Original Message-----
From: Carol Oakes [mailto:cly@evolving.com]
Sent: Monday, April 08, 2002 7:15 AM
To: tomcat-user@jakarta.apache.org
Subject: Problem building mod_webapp.so for Solaris 8

Hi --
mod_webapp.so
I have successfully installed Tomcat 4.0.3 and run in standalone mode
with j2sdk1.4.0. I am now trying to connect the Apache1.3.12  that comes
with Solaris 8 to my Tomcat 4.0.3 installation. I was able to build
mod_jk successfully.

I could not find a binary for mod_webapp.so for Solaris 8, so I
downloaded the source from
/builds/jakarta-tomcat-4.0/release/v4.0.1/src/webapp-module-1.0.1-tc401.src.
tar.gz
and attempted to follow the directions givein in the README.txt file.
The problem was that there was no configure script in the tar file.

So I downloaded the webapp-module-1.0-tc40-src.tar.gz file which does
have a configure script. After downloading, building, and installing
autoconf-2.53, m4-1.4, and libtool-1.4.2, when I follow the instructions
in the webapp README.txt, I get syntax errors when the build attempts to
compile pr_warp.c. Please see the attached file for output from the
buildconf, configure, and make instructions.

My build/platform environment is as follows:
uname shows:
  SunOS xxx 5.8 Generic_108528-10 sun4u sparc SUNW,Ultra-Enterprise
and the Sun compiler version is:
  cc: Sun WorkShop 6 update 1 C 5.2 2000/09/11
Installing the GNU compiler on this machine is not an option.

Is there a binary already built that I just haven't found yet? Am I
using the correct source? Has anyone else successfully built the webapp
module for Solaris 8 using this compiler or know what is wrong?

Thanks in advance for your help!

-- Carol



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message