tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Parham <d...@yfive.net>
Subject Make, won't create mod_webapp.so
Date Wed, 03 Apr 2002 14:30:51 GMT
I'm trying to link apache-2.0.32 to tomcat-4.0.3 using
webapp-module-1.0.1-tc401.  On a RS/6000 with AIX4.3.3

I run the ./configure --with-apxs=/app/apache-2/bin/apxs.
This appears to run correctly, no errors are returned.
I then run the make command.  It returns the following data, again no
errors.

># make
>
>make[]: Entering directory "lib"
>make[]: Invoking "make  build"
>make[]: Generating "pr_warp_defs.h" from
>"/download/webapp-module-1.0.1-tc401/java/Constants.java
>"
>make[]: Creating library "libwebapp.la"
>        /app/apache-2/build/libtool /usr/bin/gcc -rpath
>/download/webapp-module-1.0.1-tc401/lib -
>static -o libwebapp.la wa_main.lo  wa_config.lo  wa_request.lo pr_info.lo
>pr_warp.lo  pr_warp_pa
>cket.lo  pr_warp_network.lo  pr_warp_config.lo
>rm -fr .libs/libwebapp.la .libs/libwebapp.* .libs/libwebapp.*
>ar cru .libs/libwebapp.a  wa_main.o wa_config.o wa_request.o pr_info.o
>pr_warp.o pr_warp_packet.o
> pr_warp_network.o pr_warp_config.o
>ranlib .libs/libwebapp.a
>creating libwebapp.la
>(cd .libs && rm -f libwebapp.la && ln -s ../libwebapp.la libwebapp.la)
>        /app/apache-2/build/libtool --silent --mode=install
>/download/webapp-module-1.0.1-tc401/
>support/install.sh -c  libwebapp.la  /download/webapp-module-1.0.1-tc401/lib
>----------------------------------------------------------------------
>Libraries have been installed in:
>   /download/webapp-module-1.0.1-tc401/lib
>
>If you ever happen to want to link against installed libraries
>in a given directory, LIBDIR, you must either use libtool, and
>specify the full pathname of the library, or use the `-LLIBDIR'
>flag during linking and do at least one of the following:
>   - add LIBDIR to the `LIBPATH' environment variable
>     during execution
>   - use the `-Wl,-blibpath:LIBDIR:/usr/lib:/lib' linker flag
>
>See any operating system documentation about shared libraries for
>more information, such as the ld(1) and ld.so(8) manual pages.
>----------------------------------------------------------------------
>        /app/apache-2/build/libtool --silent --mode=finish
>/download/webapp-module-1.0.1-tc401/l
>ib
>Target "build" is up to date.
>make[]: Exiting directory "lib"
>
>make[]: Entering directory "apache-2.0"
>make[]: Invoking "make  build"
>Target "build" is up to date.
>make[]: Exiting directory "apache-2.0"
>Target "all" is up to date.

I've tried running the ./configure commands with various different flags.
But always the same result.  There is never a mod_webapp.so file in the
apache-2.0 dir.

If anyone has any insight they'd like to share I would be very hapy to hear
it.

thanks
David
dave@yfive.net


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message