tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wu Lu <wu...@tmctechnologies.com>
Subject RE: LoadModule webapp_module modules/mod_webapp.so
Date Wed, 24 Apr 2002 15:24:12 GMT
If you installed Apache on WinXP, there is a menu option of "Test
Configuration". You can click it to test the configuration. The actuall
command is:

"C:\Program Files\Apache Group\Apache2\bin\Apache.exe" -t -f "C:\Program
Files\Apache Group\Apache2\conf\httpd.conf" -d "C:\Program Files\Apache
Group\Apache2\."

-----Original Message-----
From: yilmaz [mailto:yilmaz@hwajet.com.tw] 
Sent: Wednesday, April 24, 2002 11:11 AM
To: Tomcat Users List
Subject: Re: LoadModule webapp_module modules/mod_webapp.so

Hi Simon,
I tried apache -t istead (i saw it from someone else's posting) and got:
apache: could not open document config file D:/Program
Files/E~1/Apache2/conf/httpd.conf
error.
As you said i changed modules/mod_webapps.so to
modules\mod_webapps.so, but still the same frustrating message :(
what do you think the problem can be?
thanks :)
----- Original Message -----
From: "Simon Stewart" <sms@lateral.net>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Wednesday, April 24, 2002 10:28 PM
Subject: Re: LoadModule webapp_module modules/mod_webapp.so


> apachectl configtest ultimately runs "httpd -t", so you could try
> "httpd.exe -t" on win32. You might also try reversing the direction of
> the file seperator in Windows:
>
> LoadModule webapp_module modules\mod_webapp.so
>
> I'm never tried Apache on Win32, but this should help.
>
> On Wed, Apr 24, 2002 at 09:51:57PM +0800, yilmaz wrote:
> > Hi Simon,
> > unfortunately i don't know how to do "apachectl configtest".
> > from command window i tried that , but didn't work.
> > >From apache monitor, when i try to start the server, it throws
> > "the requested operation has failed" error, nothing else.
> > My httpd.config is okey,  except when i add
> > "LoadModule webapp_module modules/mod_webapp.so"
> > into the httpd.config file (as it is instructed) , and restart the
apache,
> > it can't start. Obviously the problem is with the above line of code.
> > Any suggestions ?
> > Thanks :)
> > ----- Original Message -----
> > From: "Simon Stewart" <sms@lateral.net>
> > To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> > Sent: Wednesday, April 24, 2002 5:54 PM
> > Subject: Re: LoadModule webapp_module modules/mod_webapp.so
> >
> >
> > > On Wed, Apr 24, 2002 at 04:34:42PM +0800, yilmaz wrote:
> > > > Hi everyone,
> > > > i know everyone is already sick of reading problems about apache and
> > tomcat. I read almost all related mails and articles (how-to's) on the
> > internet , which didn't help.
> > > > i am working with tomcat 4.0-b7 on win 2000.
> > > > And using apcahe 2.
> > > > according to the instructions on the articles downloaded
mod_webapp.so
> > and put it under modules/ directory.
> > > > The tomact and apache both work fine without problem.
> > > > When i add
> > > > LoadModule webapp_module modules/mod_webapp.so
> > > > in my httpd.conf file, i can't get apache started. It says "the
> > requested operation has failed".
> > > > Is there any syntax error, or something else?
> > > > (note: i added the above line just under the default loadmodule
lines
> > defined in the httpd.conf file)
> > > > Any help please : (
> > >
> > > When you saw the error, had you done an "apachectl configtest" to make
> > > sure that your httpd.conf was okay? Is there anything in apache's
> > > error logs?
> > >
> > > Cheers,
> > >
> > > Simon
> > >
> > > --
> > > `The situation is completely under control. All of them were killed.'
> > >      --- Alim Razim, for the Northern Alliance, demonstrating fine
> > >          command of traditional Afghan prisoner control techniques.
> > >
> > > --
> > > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> > >
> > >
> >
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> Cheers,
>
> Simon
>
> --
> Ambivalent? Well, yes and no
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message