tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lee Newman <...@psulias.psu.edu>
Subject starting Tomcat 4.0.3 on Compaq Tru64 Unix
Date Mon, 08 Apr 2002 20:46:26 GMT
I'm having some problems starting Tomcat 4.0.3 on Compaq
Tru64 Unix.  I've looked for a FAQ that might address the problem,
because it seems like this is probably a common beginner's issue,
but I haven't been able to find any information that addresses this.  
The problem I'm seeing is, when I run startup.sh, Tomcat doesn't seem 
to be starting up.  I get the following information written to the 
screen:

 Using CATALINA_BASE:   /lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3
 Using CATALINA_HOME:   /lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3
 Using CATALINA_TMPDIR: /lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3/temp
 Using JAVA_HOME:       /usr/opt/java131

and catalina.out shows:

usage: java org.apache.catalina.startup.Catalina [ -config {pathname} ] [ -debug ] [ -nonaming
] { start | stop }

Doing a ps -Af verifies that it's not running.  I put "echo" in
front of the command where Tomcat gets started to see what it's
doing, and it shows:

/usr/opt/java131/bin/java -Djava.endorsed.dirs=/lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3/bin:/lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3/common/lib
-classpath /usr/opt/java131/lib/tools.jar:/lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3/bin/bootstrap.jar
-Dcatalina.base=/lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3 -Dcatalina.home=/lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3
-Djava.io.tmpdir=/lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3/temp org.apache.catalina.startup.Bootstrap
 start


I did notice that the temp directory 
/lcs/users/ewn/tomcat/jakarta-tomcat-4.0.3/temp didn't exist after I
unpacked the installation, so I created it, but that didn't seem to have
an effect.  I also tried running it under csh (usually I use ksh) because
we have some other software here that does need to be run under csh, but 
that didn't seem to help, either, unfortunately.

I've been searching through the archives of this list looking to see
if anyone else has had this problem and did see one person who requested
help, Dieter Lunn -- if you've solved the problem you had, would you
be willing to share what you did to fix it or give me any hints on what 
I could look into to help track this down?

Thanks very much!

Lee Newman, ewn@psulias.psu.edu


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message