tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Aborg <daniel.ab...@netengines.com>
Subject Tomcat 4.0.3 hangs when removing web application.
Date Mon, 15 Apr 2002 08:20:34 GMT
Hi!

I originally posted this message on jGuru, but got no solutions we could 
use. I'm hoping for a piece of the collective wisdom of the tomcat-user 
list in order to solve this little problem.

I'm trying to upgrade to JBoss 2.4 with Tomcat 4. Unfortunately, I've 
encountered a rather fatal problem: When Tomcat is asked to remove our 
web application, i.e. for redeploying it or when shutting down, it hangs 
with the following message:

StandardWrapper[/<context>:<servlet>]: Waiting for 1 instance(s) to be 
deallocated

Having searched the mailing list archives, I've found other people 
having similar problems with 4.0.1, and a bugzilla entry saying it's 
fixed. Woo hoo! So I downloaded Tomcat 4.0.3 and installed it, only to 
find the problem remains. Bugger.

To be more specific, the problem occurs because we have a servlet which 
holds onto its request connections for a long time. When I noticed this 
problem, I set up code in the servlet to cut the connections when it 
gets a destroy() request. Unfortunately, Tomcat never sends the servlet 
a destroy(), it just hangs waiting for the servlet's connections to 
close. If the connection closes, tomcat comes out of its wait and 
happily shuts down the web application. This should be easy to 
reproduce, unless it's me who's messed something up.

On to my question: What can I do about this?

I'd greatly appreciate any suggestions, as I'd like to upgrade to Tomcat 
4.0. All those nifty features...

Thanks!

/D

-- 
Daniel Aborg - Developer


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message