tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Oakes <...@evolving.com>
Subject Problem building mod_webapp.so for Solaris 8
Date Mon, 08 Apr 2002 13:15:18 GMT
Hi --

I have successfully installed Tomcat 4.0.3 and run in standalone mode
with j2sdk1.4.0. I am now trying to connect the Apache1.3.12  that comes
with Solaris 8 to my Tomcat 4.0.3 installation. I was able to build
mod_jk successfully.

I could not find a binary for mod_webapp.so for Solaris 8, so I
downloaded the source from
/builds/jakarta-tomcat-4.0/release/v4.0.1/src/webapp-module-1.0.1-tc401.src.tar.gz
and attempted to follow the directions givein in the README.txt file.
The problem was that there was no configure script in the tar file.

So I downloaded the webapp-module-1.0-tc40-src.tar.gz file which does
have a configure script. After downloading, building, and installing
autoconf-2.53, m4-1.4, and libtool-1.4.2, when I follow the instructions
in the webapp README.txt, I get syntax errors when the build attempts to
compile pr_warp.c. Please see the attached file for output from the
buildconf, configure, and make instructions.

My build/platform environment is as follows:
uname shows:
  SunOS xxx 5.8 Generic_108528-10 sun4u sparc SUNW,Ultra-Enterprise
and the Sun compiler version is:
  cc: Sun WorkShop 6 update 1 C 5.2 2000/09/11
Installing the GNU compiler on this machine is not an option.

Is there a binary already built that I just haven't found yet? Am I
using the correct source? Has anyone else successfully built the webapp
module for Solaris 8 using this compiler or know what is wrong?

Thanks in advance for your help!

-- Carol



Mime
View raw message