tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Giovanni P. Tirloni" <tirl...@bs2.com.br>
Subject Re: Tomcat4 and Virtual Hosts
Date Mon, 08 Apr 2002 19:31:52 GMT
On Mon, 8 Apr 2002, Giovanni P. Tirloni wrote:

> On Mon, 8 Apr 2002, Jean-Luc BEAUDET wrote:
>
> > Well, well
> >
> > Let's have some breath:
> >
> > Yu said that the actual code
> >
> > WebAppConnection conn warp localhost:8008
> >
> > WebAppDeploy  mydomain-context conn /context
> >
> > was just runnin' OK before yu declared that one below:
>
>  Yes, that was working but that works for every virtual host that I´ve
> on this server so after I so it was working I removed it.
>
> > <VirtualHost 1.2.3.4>
> >     ServerName mydomain.com
> >     ServerAlias www.mydomain.com
> >     DocumentRoot /path/mydomain.com
> >
> >     WebAppConnection mydomain-conn warp localhost:8008
> >
> >     WebAppDeploy mydomain-context mydomain-conn /context
> >  </VirtualHost>
>
>  Yes, After I realised that I couldn´t use a connection previous
> declared outside <VirtualHost> (the one I used for examples/ above) I
> declared it inside <VirtualHost> with another name and removed that
> other one. This two WebApp* lines are the only ones related to Tomcat
> inside my httpd.conf.
>
> > Right ?
> >
> > In yur server xml yu declared in the right section - that is  <Service
> > name="Tomcat-Apache"> -
> > yur Virtual host:
> >
> >  <Host name="mydomain.com">    ADD INSIDE IT the appbase="/path/to/my/webapps"
> >            <Alias name="www.mydomain.com"</Alias> I'd WRITE it THIS WAY
as said in
> > the DOc....
> >
> >            <Context path="/context" docBase="/path/mydomain.com/context"/>
> >
> >  </Host>
>
>  Well, I had the </Alias> After <Context> but changing it to before
> <Context> changed nothing.
>
> > Is that Correct ?
> >
> > After modifications, did yu restart 1) Tomcat    2) Apache ?
>
>  Yes
>
> > Could yu declare WebAppInfo and tell us about it ?
>
>  When I declared examples/ I declared webapp-info/ too and it worked
> fine.
>
>  Now I left webapp-info/ declared using connection "conn" and declared
> connection "mydomain-conn" inside <VirtualHost> host again and it said
> "duplicated" again (the error I posted before). If I don´t declare
> connection "mydomain-conn" and try to WebAppDeploy that
> "mydomain-context" using the previusly declared connection "conn" it
> says the connection is not configured.
>
>  I tried to remove both <Alias> from server.xml and ServerAlias from
> httpd.conf without success, it says connection duplicated.
>

 [replying to myself]

 Is there a document explaining how to deploy contexts with virtual
 domains ? The HOWTOs in the Tomcat´s are a bit vague for me (since
 I´m not a webapp developer, just configuring the server).

 I said I was using Tomcat 4.0.1 but in fact I´m using 4.0.4-b2

 Thanks in advance

 --
 Giovanni P. Tirloni
 BS2 Sistemas para Internet Ltda.



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message