tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jünger @ projektINTER.NET" <juen...@projektinter.net>
Subject Re: Connection Apache - Tomcat
Date Wed, 03 Apr 2002 14:26:01 GMT
thanks Gary,

that worked. (together with the docBase of course)!

Rainer


> Rainer
>
> I think tomcat4 uses the $CATALINA_HOME environment to get to your context
>
> What I did to get round it was to create a symbolic link in the tomcat
> webapps directory to point to the actual directory.
>
> So in your case:
>
> ln -s /home/wwa-m/public_html/docroot/wwa-m
/usr/local/tomcat/webapps/wwa-m
> (or something like that)
>
> Worked for me!
>
>
> ----- Original Message -----
> From: "Jünger @ projektINTER.NET" <juenger@projektinter.net>
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Sent: Wednesday, April 03, 2002 11:30 AM
> Subject: Re: Connection Apache - Tomcat
>
>
> >
> > Ho Joseph,
> >
> > thanks for your idea!
> > I was trying that before.
> (appBase="/home/wwa-m/public_html/docroot/wwa-m/")
> > but without success!
> > I of course restartet Tomact after changing server.xml and restartet
> Apache
> > as well.
> > In the error log there is still the same (old) adress listed!!
> >
> > Any further ideas?
> > Rainer
> >
> > > Your connector (server.xml) is actually set to serve from the
"webapps"
> > > directory (which is presumably found at "/usr/local/tomcat/")  There
is
> > your
> > > problem.  You have to change the connector appBase.
> > >
> > > ----------------------------------------
> > > Joseph Molnar
> > > http://www.codesta.com/
> > >
> > >
> > >
> > > ----- Original Message -----
> > > From: "Jünger @ projektINTER.NET" <juenger@projektinter.net>
> > > To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> > > Sent: Wednesday, April 03, 2002 1:23 AM
> > > Subject: Connection Apache - Tomcat
> > >
> > >
> > > Hi,
> > >
> > > the root of my webapplication is:
> > > /home/my-user/public_html/docroot/my-app/
> > >
> > > I tried to configure Apache and Tomcat to serv the web form this path
> > > without success.
> > > Apache is recognizing that webapplication when I access files within
the
> > > docroot folder but not within the wwa-m/ folder (as supposed!)
> > > Tomcat is working fine with the servic running the 8080 port.
> > > But I am getting an 404 Error wenn I directly access the wwa-m folder.
> > >
> > > server.xml:
> > >
> > > <Service name="Tomcat-Apache">
> > >
> > >     <Connector className=
> > >         "org.apache.catalina.connector.warp.WarpConnector"
> > >             port="8008" minProcessors="5"
> > >                 maxProcessors="75" enableLookups="true"
> > >                     acceptCount="10" debug="0"/>
> > >
> > >     <!-- Replace "localhost" with what your Apache
> > >         "ServerName" is set to -->
> > >    <Engine className="org.apache.catalina.connector.warp.WarpEngine"
> > >            name="apache.nandgate.com" debug="0"
> > >                appBase="webapps"> <!-- ich denke hier muß es
> passieren -->
> > >
> > >       <!-- Global logger unless overridden at
> > >           lower levels -->
> > >       <Logger className=
> > >           "org.apache.catalina.logger.FileLogger"
> > >               prefix="apache_log." suffix=".txt"
> > >               timestamp="true"/>
> > >
> > >       <!-- Because this Realm is here, an instance
> > >           will be shared globally -->
> > >       <Realm className=
> > >          "org.apache.catalina.realm.MemoryRealm" />
> > >
> > >     </Engine>
> > >
> > >   </Service>
> > >
> > >
> > > httpd.conf:
> > > DocumentRoot /home/wwa-m/public_html/docroot/wwa-m/
> > >
> > > WebAppConnection warpConnection warp localhost:8080
> > > WebAppDeploy wwa-m warpConnection /wwa-m/
> > > WebAppInfo /webapp-info
> > >
> > > in the Apache logfile I am getting an error:
> > > Cannot find "/usr/local/tomcat/webapps/wwa-m" for appl. "wwa-m" host
> > > www.wasserwirtschaftsamt-muenchen.de
> > > Where does Apache get this old path from ?????????????
> > >
> > > Any ideas ??
> > >
> > > thanx Rainer
> > >
> > >
> > >
> > > --
> > > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> > >
> > >
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> >
> >
>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message