tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Costas Stergiou" <cst...@aias.gr>
Subject mod_jk: ajp13: cpu load problem with apache
Date Wed, 01 May 2002 06:55:57 GMT
Hi,
I have an installation of Apache 1.3.19 + Tomcat 4.0.3
on a aix4.3 machine with IBM JDK 1.3.0. I have two tomcat
engines and I use the lb worker of mod_jk to balance user
request to these two engines. 

The problem is that some httpd processes seem to go
into some cpu performance tasks and start consuming all
the cpu of the machine (2processors, 2GB mem). After
some time almost all available CPU is consumed by the
apache processes. If I kill the child processes that cause
the problem, the load falls back to normal. At the same time,
I notice that I have excessive CPU usage in one of the
tomcat instances.

The problem keeps recurring all the time (almost every hour).
I read in the mail-archives about similar problems but I didn't 
find a good answer. 

The version of mod_jk is the one in jakarta-tomcat-connectors-4.0.2.01
I compiled the source on the same machine (aix).

I have to say that I have noticed similar problems on many more 
apache installations that have similar installations (apache, lb + 
2 or more tomcat engines) with older versions of mod_jk and tomcat.

Actually, the above problem makes the lb worker unusable since 
I cannot trust the setup in my production environment. 

Please, any idea or patches or whatever will be very helpful.
Thanks very much for any ideas,
Costas




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message