tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Höglind <a...@hoglind.com>
Subject Re: jk_nt_service fails (error 1067)
Date Tue, 09 Apr 2002 08:55:08 GMT
Hi,
I'm using Tomcat 4.03 and this is what I found at the end of the file,
*****
#wrapper.cmd_line=$(wrapper.javabin) -Djava.security.policy=="$(wrapper.tomcat_policy)" -Dtomcat.home="$(wrapper.tomcat_home)"
-classpath $(wrapper.class_path) $(wrapper.startup_class) -config $(wrapper.server_xml) 

wrapper.cmd_line=$(wrapper.javabin) -Xrs -Djava.security.policy=="$(wrapper.tomcat_policy)"
-Dtomcat.home="$(wrapper.tomcat_home)" -classpath $(wrapper.class_path) $(wrapper.startup_class)
-config $(wrapper.server_xml) start
*****

Soo it seems like it is already fixed by default.

Thanx,
Alexander

----- Original Message ----- 
From: "Lecaros, Noel" <noel.lecaros@pfizer.com>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Monday, April 08, 2002 6:41 PM
Subject: RE: jk_nt_service fails (error 1067)


Hi,

Have you looked in %TOMCAT_HOME%\logs\jvm.stderr?  This message looks
familiar.  There appears to be an issue with the wrapper.properties file
(the one you should specify as a command-line argument to jk_nt_service.exe)
in that the property "wrapper.jvm.options" is not being read properly.
Either remove this from the wrapper.cmd_line (found at the end of the file)
or set "wrapper.jvm.options=-Xrs".  This issue is actually documented
"somewhere" in the mailing list, which makes a case for better documentation
for Tomcat.

Regards,

Noel Lecaros

-----Original Message-----
From: Alexander Höglind [mailto:alex@hoglind.com]
Sent: Monday, April 08, 2002 9:19 AM
To: Tomcat User
Subject: jk_nt_service fails (error 1067)


Hi,
I'm using Tomcat 4.03 on win2000 server(sp2) and IIS 5.0
Tomcat seems to work fine (mysite.com:8080) but I can't get jk_nt_service to
work.
I have disabled tomcat.exe in my services and restarted the server, but the
service doesn't start. My operating system is in swedish but this is an
error I found in this group that looks like it:
***
A system error has occurred.
System error 1067 has occurred.
The process terminated unexpectedly.
***
I couldn't find an answer to the old message so I ask again. Why can't I
have this service started. Just to see that it wasn't my server that was
messed up, I installed tomcat on win2000 prof (sp2) with default IIS and it
generates the same error.

If I try to start the service in the Command Prompt (jk_nt_service -s
Tomcat) and it generates this error:
*****
Asked (and given) winsoc
Starting Tomcat.
Tomcat failed to start.
*****

The service is started by following command: jk_nt_service.exe Tomcat in
win2000 services.
If I try that in the Command Promt I get the following error:
****
Asked (and given) winsock 1.1
Error: StartServiceCtrlDispatcher failed.
***

Can it have to do with spaces in my tomcat installation dir. d:\Java\Apache
Tomcat 4.0 ?


Thanx for any help,
Alexander Höglind



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message