tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Trasuk" <>
Subject RE: What is different when running tomcat 4 as a service?
Date Thu, 11 Apr 2002 23:50:21 GMT
I ran into the same thing trying to use the COMM api's under the service
option.  In my case, it turned out that although I had the JDK installed,
the service actually runs using the JRE (I think the installer actually
installs the JRE).  So when I put the extensions into C:\Program
Files\Javasoft\JRE\1.3.1\lib\ext (rather than my usual \jdk1.3.\lib\ext),
everything worked fine.  I haven't seen anything else that bit me while
trying to use Tomcat as a service.  It actually works fairly well as a
miniature application server!.


Greg Trasuk, President
StratusCom Manufacturing Systems Inc. - We use information technology to
solve business problems on your plant floor.

> -----Original Message-----
> From: Jan Bentzen []
> Sent: April 11, 2002 14:58
> To: tomcat-user
> Subject: What is different when running tomcat 4 as a service?
> HI
> I recently tried running my Tomcat 4.0.1 as a service in w2k.
> (just clicking the service option when installing). Much to
> my surprise our webapplication no longer worked!
> Apparantly JAR files placed in jdk extensions directory could
> not be found when bootstrapping. (Due to several things which
> I wont go into here, they must be there).
> Why is this? How do I make it so that they can be found when
> runnning as a service? And what else differs when running as
> a service? Where can I find updated information about this
> (for tomcat 4)?
> Thanks
> Beno

To unsubscribe:   <>
For additional commands: <>
Troubles with the list: <>

View raw message