tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brendan Colthurst <bren...@colthurst.com>
Subject multipart/form-data Binary File Upload Bug and Connector Culprits
Date Sat, 09 Mar 2002 18:39:19 GMT
Greetings Users and Developers,

I think I need to compile the latest mod_webapp connector to fix a
multipart/form-data binary File Upload bug 
with the tomcat/warp/apache connection.  (bug:
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3534)

Summary of bug:  binary multipart/form-data file uploads get corrupted due
to a mod_webapp connector bug.

I'm currently using:
tomcat 4.0.1
apache 1.3.22
red hat linux 7.2
webapp-module-1.0-tc40-linux-glibc2.2
virtual hosting and multiple tomcat instances

Questions:
0.  Is there an easier way to solve the problem (use another connector,
newer version of tomcat...)?
1.  Are there mod_webapp binaries available that include the fix for this bug?
(I assume not, so I'm trying to compile the source files:)
2.  Is it safe to assume that 
http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.3/src/jakar
ta-tomcat-connectors-4.0.2-01-src.tar.gz
contains a newer source version of 
http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0/src/webapp-
module-1.0-tc40-src.tar.gz
?

I assumed so, and tried to compile mod_webapp from the more recent file.


Can I assume that "configure.in" is the same as "configure"?
Because the
/jakarta-tomcat-connectors-4.0.2-01-src/webapp/README.txt
file says, in order to build mod_webapp, to run: 

    ./configure --with-apxs
    make

but I only found a "configure.in" file.  I assumed I could run it just the
same.
I ran into this problem: 

[root@www webapp]# ./configure.in --with-apxs
./configure.in: dnl: command not found
./configure.in: dnl: command not found
./configure.in: dnl: command not found
./configure.in: dnl: command not found
./configure.in: line 5: syntax error near unexpected token `(c'
./configure.in: line 5: `dnl          Copyright (c) 1999-2001 The Apache
Software Foundation.'
[root@www webapp]#

If anyone can help, I'd appreciate it a lot.  My main goal is to get binary
file uploads working on my server, and the only 
thing I know for sure is that it's a tomcat/warp/apache problem (the
multipart parser work i'm using (com.oreilly.servlet.multipart) works like
a champ on older versions of tomcat and ajp).

Please pardon my perhaps naive questions.

Thanks,
Brendan
brendan@colthurst.com



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message