tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack Frosch" <>
Subject Apache 1.3.23 + Tomcat 4.01 + Warp
Date Sat, 02 Feb 2002 01:23:41 GMT
I'm trying to get Apache 1.3.23 to work with Tomcat 4.01. On my development
machine, I've installed both Tomcat and Apache to test the configurations.

The installs and initial configurations seemed to go okay at first because
both Tomcat and Apache work well separately. (I did add the LoadModule
directive like: LoadModule webapp_module modules/ However,
when I couldn't get a connection to Tomcat, I noticed Apache logs the
following error on startup:

[Fri Feb 01 14:12:36 2002] [error] Connection "warpConnection" cannot
[Fri Feb 01 14:12:36 2002] [error] Cannot open connection "warpConnection"

What causes this connection to fail? Is there a way to test it outside of
Apache to isolate whether it's an issue with my Tomcat or my Apache


Jack Frosch

For more info:

The "warpConnection is defined in a Virtual Host which is defined as


# is mapped in my HOSTS file to; i.e.
 DocumentRoot "E:/Apache/com/testdomain1/www"
 ErrorLog logs/
 CustomLog logs/ common

 WebAppConnection warpConnection warp
 WebAppDeploy examples warpConnection /examples

 WebAppInfo /webapp-info

My Tomcat server.xml file defines the Apache-Connector service as:
 <!-- Define an Apache-Connector Service -->
 <Service name="Tomcat-Apache">
      port="8008" minProcessors="5" maxProcessors="75"
      enableLookups="true" acceptCount="10" debug="0"/>
      name="" debug="0" appBase="webapps">
      <Logger className="org.apache.catalina.logger.FileLogger"
      prefix="apache_warp_log." suffix=".txt" timestamp="true"/>
      <Realm className="org.apache.catalina.realm.MemoryRealm" />

To unsubscribe:   <>
For additional commands: <>
Troubles with the list: <>

View raw message