tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Corey <>
Subject Is Apache <-warp-> Tomcat a Myth?
Date Thu, 07 Feb 2002 10:17:43 GMT
Hi All,

I'm having such a huge amount of trouble with this, I'm hoping someone can 
suggest something.  It just doesn't make's like software 
engineering...I was 90% of the way there in 1 hour, but the final 10% has 
taken me another 12 hours, and it still doesn't work!

I've got a Linux 2.2.19 box (pre glibc-2.2, so prebuilds depending on 
glibc-2.2 won't work).

I'm running Apache 1.3.20, and Tomcat 4.0.1, jdk 1.3.0.

I've compiled my own warp connector module, and set everything up as per the 
sun web page here: 
which I thought was going to provide everything I needed.

My httpd.conf file has: 

LoadModule webapp_module libexec/
WebAppConnection warpConnection warp
WebAppDeploy sample warpConnection /sample/

I went through the development process as outlined on the tomcat site, so 
now, I've got a lovely little project directory (hello world, of course), a 
web.xml that specifies the servlet.  The project is called 'sample'.

(NOTE: as shown below *is* shown 
above. I could see no difference in my tests one way or another, as I don't 
have virtual hosts turned on in Apache.)

So, after a deploy and a tomcat restart, my tomcat application can now be 

The index.html page is pulled up, and when the link is clicked it takes the 
user to the servlet served up by Tomcat.

Now, let's try this on Apache 1.3.20:

Nothing is shown in Tomcat's logs, and so apache tries to offer the 
index.html, which of course doesn't exist as far as Apache is concerned.

tomcat 'sees' this one, judging by the logs:
2002-02-07 09:40:48 WarpEngine[]: Mapping request
2002-02-07 09:40:48 WarpHost[]: Mapping request for 
2002-02-07 09:40:48 StandardContext[/sample]: Mapping contextPath='/sample' 
with requestURI='/sample/' and relativeURI='/'
2002-02-07 09:40:48 StandardContext[/sample]: Decoded relativeURI='/'
2002-02-07 09:40:48 StandardContext[/sample]:   Trying exact match
2002-02-07 09:40:48 StandardContext[/sample]:  Mapped to servlet 'default' 
with servlet path '/' and path info 'null' and update=true
2002-02-07 09:40:48 default: DefaultServlet.serveResource:  Serving resource 
'/' headers and data

However, tomcat apparently denies any knowlege, so Apache tries to load the 
index.html file, which still doesn't exist:

Strangely, though, the servlet still does exist:

So what gives?


To unsubscribe:   <>
For additional commands: <>
Troubles with the list: <>

View raw message