tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Takeshi L Toyohara" <take...@toyohara.net>
Subject servlet-mapping problem
Date Fri, 22 Feb 2002 21:53:57 GMT
howdy,

i am trying to just play around with tomcat and try to get some servlets
running.  I am having a problem getting the servlet-mapping to work in my
web.xml and am wondering if i can get you guys to help out.


here's my web.xml.  the servlet-mapping tag works only the way it is now (im
guessing b/c its actually only using the invoker servlet).  i cant change it
to anything else, such as /wars or /blah, etc. and get it to work.  any
ideas?

any info is much appreciated!

cheers
t


<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>
    <display-name>WAR TEST</display-name>
    <description>Testing WAR'ing files</description>

    <servlet>
        <servlet-name>warservlet</servlet-name>
        <description>the hello dude servlet</description>
        <servlet-class>wartest.HelloDudeServlet</servlet-class>
        <init-param>
             <param-name>helloparam</param-name>
             <param-value>Hello Dude</param-value>
        </init-param>
    </servlet>

  <servlet-mapping>
    <servlet-name>warservlet</servlet-name>
    <url-pattern>/servlet/warservlet</url-pattern>
  </servlet-mapping>

</web-app>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message