tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sucharitha Panthika" <spanth...@certivo.net>
Subject RMI remote Method which returns File object.
Date Thu, 07 Feb 2002 01:16:36 GMT
Hey

I have a qution using RMI to return files . If I have a a remote method 
public File getFile();  
method in a Server and I implemented this method to return one file from
my local drive C:\.  When the remote Client from different system calls
this method should it return the my File 
to that Client or not.  i have give allpermission in the policy files.

I have similar example. When I run the Client from a different system I
don't get the File
object instead when I run the Client from myy system in another window
without the required classes in the classpath I get the File.  

Can Any one let me know what could be the problem? I am attaching the
Server, ServerImpl, Client and policy files for review if required.


Sucharitha



-----Original Message-----
From: Gearoid Coughlan [mailto:gearoid.coughlan@kapookigames.com]
Sent: Wednesday, February 06, 2002 3:32 PM
To: 'Tomcat Users List'
Subject: tomcat 4.0 + apache 1.3.12 + mod_jk


Hi

I am getting the following error reported in mod_jk.log when
executing servlets
--
[Wed Feb 06 23:14:56 2002]  [jk_connect.c (143)]: jk_open_socket,
connect() 
failed errno = 146
[Wed Feb 06 23:14:56 2002]  [jk_ajp13_worker.c (196)]: In 
jk_endpoint_t::connect_to_tomcat, failed errno = 146
[Wed Feb 06 23:14:56 2002]  [jk_ajp13_worker.c (635)]: Error connecting
to 
the Tomcat process.
[Wed Feb 06 23:14:56 2002]  [jk_ajp13_worker.c (848)]: In 
jk_endpoint_t::service, send_request failed in send loop 2
---

Im running apache version 1.3.12
with tomcat 4.0.x

when I run tomcat 3.0 everything is fine.
BTW im running this on a Sparc Solaris SunOS 8

Any ideas..

thanks
gearoid



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message