tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "GOMEZ Henri" <hgo...@slib.fr>
Subject Re: Tomcat 4.0.2 - Startup fails after moving xerces.xml from /common/lib to /server/lib
Date Tue, 12 Feb 2002 09:09:45 GMT
>> I am using xerces 2.0.0 in one of my webapps so I need to move xerces.jar
>> out of /common/lib and into /server/lib. This works just fine with
>>4.0.2-b2.
>> With 4.0.2 If I keep xerces.jar in /common/lib and use xerces.jar 1.4.3 in
>> my web app everything starts up just fine. But if I move xerces.jar into
>> /server/lib I get the exception below. I suspect that this is due to the
>> ClassLoader bug fixes done between 4.0.2-b2 and 4.0.2. Is there any
>> workaround for this?

>Ok, I understand the problem now.

>The thing is that Tomcat will now refuse to load the JAXP base classes from
>the webapp repositories. There are lots of problems with JAXP overall, so I
>prefered to avoid the classcasts problems, which didn't have any clean
>workaround. Here, it's very easy to fix (don't worry, having Xerces or
>jaxp.jar in server/lib won't create any more classloading problems :)).

>Sorry, the bug report you filed was incomplete, so the explanation I put in
>there was not the right one.

What about including xml-common jar which include jaxp and
have it on server/lib ?

Then user could try to play with Xerces 2.0 or older or Crimson,
since the DOM/SAX/W3C APIs will be preloaded in CL since there are
in server ?

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message