tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Layman <randy.lay...@aswethink.com>
Subject RE: Path error in Tomcat startup scripts on Linux
Date Mon, 25 Feb 2002 15:54:33 GMT

	Is it possible that in your Context definition in either server.xml
or apps-XXX.xml you are specifying an absolute path instead of a relative
one?

	Randy


> -----Original Message-----
> From: Luke Studley [mailto:Luke.Studley@cerillion.com]
> Sent: Monday, February 25, 2002 11:24 AM
> To: 'Tomcat Users List'
> Subject: Path error in Tomcat startup scripts on Linux
> 
> 
> {See also thread [Apache Tomcat/4.0.2 - HTTP Status 404 - 
> /examples/jsp/]
> which seems a similar problem}
> 
> Have an application which works fine on Win2k with Tomcat 
> 4.0.1 - but is
> failing on Linux.
> 
> I have an app under $CATALINA_HOME/webapps/webcare/web - and 
> an entry in
> server.xml which maps to it.
> 
> However in the logs on Linux Catalina apparently binds perfectly to
> $CATALINA_HOME/webapps/ROOT but fails miserably when trying 
> to bind to my
> app.
> 
> In the log it says it fails to find the app at /webcare/web - and sure
> enough if I create a directory at /webcare/web - i.e. in the 
> filesystem root
> directory - it works again.
> 
> Looks like something in the unix version is not picking up 
> paths properly.
> Anybody else come across this - and especially anyone know 
> how to fix it?
> 
> Regards
> 
> Luke
> 
> 
> 
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> 

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message