tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Jussel" <Martin.Jus...@marel.at>
Subject AW: Tomcat & IIS & Servlets
Date Fri, 08 Feb 2002 13:34:38 GMT
Hi,

Thanx for your help. I checked the IIS log and found lines like that:

[...]
2002-02-08 13:29:59 192.168.0.38 - 192.168.0.3 80 GET
/kunden/servlet/Abbildung picID=16$08517270 404
[...]

I think this is what you described under "1." and so I've to modify the
uriworkermap.properties. Can you help me how to modify?

Martin




-----Urspr√ľngliche Nachricht-----
Von: Randy Layman [mailto:randy.layman@aswethink.com]
Gesendet: Freitag, 08. Februar 2002 13:24
An: 'Tomcat Users List'
Betreff: RE: Tomcat & IIS & Servlets



	When you want to run servlets, you do need to modify your
mapping.
However, people don't generally call servlets from /servlet/className
any
more.  Its more typical that you would have some specific URLs.

	There are two places where you might be having problems:
	1.  IIS doesn't recognize that it must forward the request.  To
check this you need to look at your IIS log files and see if you are
getting
404 errors for the servlet requests, or if they have been rewritten to
the
ISAPI Redirector.  If so you need to modify the uriworkermap.properties.
	2.  Tomcat doesn't recognize the URL passed from IIS as a valid
servlet URL.  To check this you need check the Tomcat logs for 404
errors.
If this is the case then you need to either create servlet mappings in
your
web.xml file or change the URL that you are using.

	Randy

> -----Original Message-----
> From: Martin Jussel [mailto:Martin.Jussel@marel.at]
> Sent: Friday, February 08, 2002 4:50 AM
> To: Tomcat Users List
> Subject: Tomcat & IIS & Servlets
> 
> 
> Hi,
> 
> Tomcat is running fine with IIS. I can surf .jsp pages and 
> JDBC is also
> working. But I've troubles with servlets. Placing a servlet in
> WEB-INF/classes seems not to work. Is there any basic
> (uriworkermap.properties?) or webapp specific (apps*.xml) 
> configuration
> needed do get it work?
> 
> my uriworkermap.properties currently looks like described in howto
> documentation:
> default.worker=ajp13
> /*.jsp=$(default.worker)
> 
> -> jsp's are running
> 
> But is it not needed to add a line like this for servlets?
> /servlet/*=$(default.worker)
> 
> (I did it but servlets still not work)
> 
> Martin
> 
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> 

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message