tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry Isaacs <Larry.Isa...@sas.com>
Subject RE: Tomcat doesn't work with IIS (repost)
Date Thu, 07 Feb 2002 13:22:36 GMT
I don't know if it is a typo, but what you show
below has mapped "example" and "examples" (plural) is
being requested.

Cheers,
Larry


-----Original Message-----
From: Scott Adamson [mailto:scottadamson@upe.com.au]
Sent: Wednesday, February 06, 2002 7:27 PM
To: Tomcat Users List
Subject: Tomcat doesn't work with IIS (repost)


I'm trying to setup Tomcat 4.0 to work with IIS 5.0 on Windows 2000. As follows :

Software -
    Installed jdk1.3.1_01 to d:\jdk1.3.1_01\
    Installed Tomcat 4.01 to d:\Apache Tomcat 4.0\
    Installed isapi_redirect.dll to d:\Apache Tomcat 4.0\bin\   This came from the 3.2.3 distribution
as it is not included in 4

IIS -
    Added 'jakarta' virtual directory to the default web site
    Added isapi_redirect as an isapi filter under the computer name, succesfully loaded
    Added an application extension for .jsp pointing to isapi_redirect.dll

Tomcat - 
    Uncommented ajp13 stuff from server.xml
    Added 

    #
# worker.tomcat_home should point to the location where you
# installed tomcat. This is where you have your conf, webapps and lib
# directories.
#
worker.tomcat_home=D:\Apache Tomcat 4.0

#
# worker.java_home should point to your Java installation. Normally
# you should have a bin and lib directories beneath it.
#
worker.java_home=D:\jdk1.3.1_01
 


    to worker.properties

    Changed uriworkermap.properties to 


 Default worker to be used through our mappings
 #
 default.worker=ajp13

 #
 # Sites to be redirected to Tomcat
 #

 /example=$(default.worker)
 /example/*=$(default.worker)


    Added /conf/jk/wrapper.properties

wrapper.tomcat_home=d:\Apache Tomcat 4.0
wrapper.java_home=d:\jdk1.3.1_01


    See the attached screenshot of my registry

    
Nothing works execept from port 8080, I have checked isapi_redirect.log, it gets the following
entry for every request (returns a 404 error) -

[Thu Feb 07 11:25:28 2002]  [jk_isapi_plugin.c (555)]: HttpFilterProc started
[Thu Feb 07 11:25:28 2002]  [jk_isapi_plugin.c (600)]: In HttpFilterProc Virtual Host redirection
of /localhost/examples/jsp/index.html
[Thu Feb 07 11:25:28 2002]  [jk_uri_worker_map.c (351)]: Into jk_uri_worker_map_t::map_uri_to_worker
[Thu Feb 07 11:25:28 2002]  [jk_uri_worker_map.c (368)]: Attempting to map URI '/localhost/examples/jsp/index.html'
[Thu Feb 07 11:25:28 2002]  [jk_uri_worker_map.c (456)]: jk_uri_worker_map_t::map_uri_to_worker,
done without a match
[Thu Feb 07 11:25:28 2002]  [jk_isapi_plugin.c (606)]: In HttpFilterProc test Default redirection
of /examples/jsp/index.html
[Thu Feb 07 11:25:28 2002]  [jk_uri_worker_map.c (351)]: Into jk_uri_worker_map_t::map_uri_to_worker
[Thu Feb 07 11:25:28 2002]  [jk_uri_worker_map.c (368)]: Attempting to map URI '/examples/jsp/index.html'
[Thu Feb 07 11:25:28 2002]  [jk_uri_worker_map.c (456)]: jk_uri_worker_map_t::map_uri_to_worker,
done without a match
[Thu Feb 07 11:25:28 2002]  [jk_isapi_plugin.c (638)]: HttpFilterProc [/examples/jsp/index.html]
is not a servlet url
[Thu Feb 07 11:25:28 2002]  [jk_isapi_plugin.c (647)]: HttpFilterProc check if [/examples/jsp/index.html]
is points to the web-inf directory

I don't get anything in the IIS log.

Can anyone see whats going on here ? or think of anything that I have forgotten to do ?

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message