tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eswar.K" <esw...@erunway.com>
Subject RE: Apache does not load images!!
Date Thu, 28 Feb 2002 12:21:16 GMT
hi ricky,

i am using mod_jk only and not mod_webapp. any clue why it is happening?

Eswar K. J. A

-----Original Message-----
From: Ricky Leung [mailto:ricky@booksense.com]
Sent: Thursday, February 28, 2002 5:05 AM
To: Tomcat Users List
Subject: RE: Apache does not load images!!


are you using mod_webapp?  I find this to be a problem when using apache and
mod_webapp, but it went away once I use it on Solaris.  mod_jk doesn't have
this problem either.

-----Original Message-----
From: Eswar.K [mailto:eswark@erunway.com]
Sent: Wednesday, February 27, 2002 8:56 AM
To: Tomcat Users List
Subject: RE: Apache does not load images!!



sometimes some images gets loaded and sometimes some others...
and sometimes all of them are shown.

The path of  the image is not a problem, bcos if it was, i should be
consistently get the problem for the same image, which is not happening.

Eswar

-----Original Message-----
From: Phil Shrimpton [mailto:phil@shrimpton.co.uk]
Sent: Wednesday, February 27, 2002 3:27 PM
To: Tomcat Users List; Eswar.K
Subject: Re: Apache does not load images!!


On Wednesday 27 February 2002 10:39, Eswar.K wrote:

Hi,

> tomcat has been integrated with apache with mod_jk.  When I send a request
> directly to tomcat(post 8080), all the images are loaded appropriately,
but
> when i am sending a requet to apache(port 80), few images are not being
> loaded. What should be done to avoid such a problem?

I had the same problem.  What is was, was that the URI I was using for the
imgaes was

/images/myimage.gif

Which when used via Apache/mod_jk were being request from Apache's doument
root.

Changing the URI to...

images/myimage.gif  (no initial slash)

Fixed the problem

Phil


--
Linux 2.4.4-4GB
  9:55am  up  2:27,  1 user,  load average: 0.20, 0.47, 0.41

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message