tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cleber Hostalácio de Melo <cle...@mg.gov.br>
Subject Re: Tomcat x Apache
Date Wed, 27 Feb 2002 19:01:23 GMT

When I start the Tomcat (first) and Apache, the logs entries became:

myServ_examples_log.2002-02-27.txt (Tomcat)

2002-02-27 15:49:14 WebappLoader[/examples]: Deploying class repositories to
work directory /var/tomcat4/work/myServer/examples
2002-02-27 15:49:14 WebappLoader[/examples]: Reloading checks are enabled for
this Context
2002-02-27 15:49:14 StandardManager[/examples]: Seeding random number generator
class java.security.SecureRandom
2002-02-27 15:49:14 StandardManager[/examples]: Seeding of random number
generator has been completed
2002-02-27 15:49:19 ContextConfig[/examples]: Configured an authenticator for
method FORM
2002-02-27 15:49:20 ContextListener: contextInitialized()
2002-02-27 15:49:20 SessionListener: contextInitialized()
2002-02-27 15:49:20 ContextListener:
attributeReplaced('org.apache.catalina.WELCOME_FILES',
'[Ljava.lang.String;@765a16')
2002-02-27 15:49:20 StandardWrapper[/examples:default]: Loading container
servlet default
2002-02-27 15:49:21 default: init
2002-02-27 15:49:21 StandardWrapper[/examples:invoker]: Loading container
servlet invoker
2002-02-27 15:49:21 invoker: init
2002-02-27 15:49:21 jsp: init

error_log (Apache)

Wed Feb 27 16:01:38 2002] [info] created shared memory segment #16768
[Wed Feb 27 16:01:38 2002] [notice] Apache/1.3.22 (Unix)  (Conectiva/Linux)
PHP/4.1.1 configured -- resuming normal operations
[Wed Feb 27 16:01:38 2002] [info] Server built: Oct 18 2001 13:34:44
[Wed Feb 27 16:01:38 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)

The entries that you mentioned in server.xml are:

<Service name="Tomcat-Apache">

    <Connector className="org.apache.catalina.connector.warp.WarpConnector"
     port="8008" minProcessors="5" maxProcessors="75"
     enableLookups="true" appBase="webapps"
     acceptCount="10" debug="0"/>

    <!-- Replace "localhost" with what your Apache "ServerName" is set to -->
    <Engine className="org.apache.catalina.connector.warp.WarpEngine"
     name="myServ" debug="0" appBase="webapps">

      <!-- Global logger unless overridden at lower levels -->
      <Logger className="org.apache.catalina.logger.FileLogger"
              prefix="apache_log." suffix=".txt"
              timestamp="true"/>

      <!-- Because this Realm is here, an instance will be shared globally  -->
      <Realm className="org.apache.catalina.realm.MemoryRealm" />

    </Engine>

  </Service>

Thank you for your comments.


Cleber
John Wadkin wrote:

> Your interpretation of the problem seems accurate. catalina.out and apache's
> error log should tell you more. Does <engine> in <Service
> name="Tomcat_Apache"> in server.xml have a <host> nested within it and the
> examples context defined within the <host>?
>
> John
>
> -----Original Message-----
> From: Cleber Hostalácio de Melo [mailto:cleber@mg.gov.br]
> Sent: 27 February 2002 16:25
> To: tomcat-user@jakarta.apache.org
> Subject: Tomcat x Apache
>
> Hi,
>
> I have linux  (kernel 2.4.5), apache 1.3.19 and
> Tomacat 4.0.2
>
> Tomcat are working well with the url:
>   http://Myserv:tomcat_port/examples/jsp/index.html
>
> But when I try to access this application from Apache with the
> URL:
>
>   http://Myserv/examples/jsp/index.html
>
> I receive the message in my browser:
>
> Forbidden
> You don't have permission to access /examples/jsp/index.html on this
> server.
>
> The corresponding entries in the Apache logs are:
>
> httpd/logs/access.log:
>   "GET /examples/jsp/index.html HTTP/1.0" 403 301
>
> httpd/logs/error.log:
>   [error] [client xxx.xxx.xxx.x] (2)No such file or directory: cannot
> read directory for multi: /examples/jsp/
>
> There is no entry in the Tomcat logs which looks like that Apache is not
>
> even trying to
> connect to Tomcat.
>
> My configuration files are:
>
> httpd.com
>
> .....
> ServerName myServer
> ServerType standalone
> ServerRoot /etc/httpd
> ......
> LoadModule ....
> LoadModule webapp_module libexec/mod_webapp-1.0-eapi.so
> ......
> AddModule    ....
> AddModule mod_webapp.c
> ......
> DocumentRoot "/home/myDocs"
> ......
> WebAppConnection Tomcat_Apache warp localhost:8008
> WebAppDeploy examples Tomcat_Apache /examples/
>
> server.xml
>
> .....
> <Service name="Tomcat_Apache">
> <Connector
>   className="org.apache.catalina.connector.warp.WarpConnector"
>   port="8008" minProcessors="5" maxProcessors="75"
>   enableLookups="true"
>   acceptCount="10" debug="0"/>
>
>   <!-- Replace "localhost" with what your Apache "ServerName" is set to
> -->
>   <Engine className="org.apache.catalina.connector.warp.WarpEngine"
>    name="localhost" debug="0" appBase="webapps">
>    .....
>    </Engine>
> </Service>
>
> Anyone has any idea what could be the problem?
>
> Thanks.
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

Mime
View raw message