tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cleber Hostalácio de Melo <cle...@mg.gov.br>
Subject Re: Tomcat 4 interaction with apache 2.0
Date Wed, 27 Feb 2002 17:33:59 GMT
I think the line:

LoadModule webapp_module modules/mod_webapp.so

should be put in httpd.conf under Apache home directory/conf.

Look at

http://dcb.sun.com/practices/howtos/tomcat_apache.jsp

I hope it helps.


Regis Muller wrote:

> HI all,
> I ma trying to make work tomcat 4.0.2 with apache 2.0, I added the
> following line at the end of the httpd.conf file :
> Include /etc/tomcat4/conf/tomcat4.conf
> which content is :
>
> # tomcat /etc/rc.d script example configuration file
> # Use with version 1.07 of the scripts or later
>
> # Where your java installation lives
> # JAVA_HOME=/usr/java/jdk
> JAVA_HOME="/opt/IBMJava2-13"
>
> # You can pass some parameters to java
> # here if you wish to
> #JAVACMD="$JAVA_HOME/bin/java -Xminf0.1 -Xmaxf0.3"
>
> # Where your tomcat installation lives
> # That change from previous RPM where TOMCAT_HOME
> # used to be /var/tomcat.
> # Now /var/tomcat will be the base for webapps only
> CATALINA_HOME="/var/tomcat4"
> JASPER_HOME="/var/tomcat4"
> CATALINA_TMPDIR="/var/tomcat4/temp"
>
> # What user should run tomcat
> TOMCAT_USER="tomcat4"
>
> # You can change your tomcat locale here
> #LANG=en_US
>
> # If you wish to further customize your tomcat environment,
> # put your own definitions here
> # (i.e. LD_LIBRARY_PATH for some jdbc drivers)
> # Just do not forget to export them :)
>
> LoadModule webapp_module modules/mod_webapp.so
>
> ------
> I also have the mod_jk.so available I don't know which to use or why.
>
> When I launch apache here is what I get :
>
> ./apachectl start
> Syntax error on line 31 of /etc/tomcat4/conf/tomcat4.conf:
> Cannot load /usr/local/apache2/modules/mod_webapp.so into server:
> /usr/local/apache2/modules/mod_webapp.so: undefined symbol: ap_table_get
>
> ./apachectl start: httpd could not be started
>
> Anyone has evre encountered this problem ? if so, please tell me what I
> did wrong.
> Thanks in advance
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message