tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank <...@netscape.net>
Subject Re: Tomcat 4 and Apache
Date Mon, 25 Feb 2002 13:05:41 GMT
I had the same problem

here is the relevant code for /etc/conf/httpd.conf

*** insert at the end of LoadModules
LoadModule webapp_module modules/mod_webapp.so

***** insert at end of AddModules
AddModule mod_webapp.c

**** add the virtual host www.testdomain.com where shown
# Virtual hosts


# Virtual host Default Virtual Host
<VirtualHost _default_:*>



   ServerName  _default_

  DirectoryIndex  index.php index.html index.htm index.shtml


   ServerSignature email











   LogLevel  warn
   HostNameLookups off




</VirtualHost>

#NameVirtualHost 127.0.0.1

<VirtualHost www.testdomain.com>
ServerName www.testdomain.com
ServerAdmin root@localhost
DocumentRoot "/var/www/html"

WebAppConnection testWarp warp www.testdomain.com:8008
WebAppDeploy examples testWarp /examples/
WebAppDeploy workout testWarp /workout/
</VirtualHost>

define a host in your Hosts file like
www.testdomain.com 192.168.1.200 Mendelsohn

Configured thusly,   you can access servlets from outside as 
http://Mendelsohn/workout/servlet/DBOopen for instance.  So if you have 
an Applet which calls a servlet, this will work fine (it's rally 
executing from outside)

A flaw in this arrangement is that from inside you need to do 
http://www.testdomain.com/workout/servlet/DBOpen  I think this is 
fixable, but haven't gotten to it yet.


I haven't seen a big performance increase from this, but you would need 
to implement this rather than tomcat standalone for security reasons I 
think.


Also you MUST start tomcat before apache.

ml.duske@gmx.net wrote:

> Hi everyone,
> 
> I'm sorry that I'm probably the 100th person to ask this, but I have
> searched google groups and the archives of this mailing list, both of which
> failed to help me setting up Tomcat 4.01 with Apache 1.3.23 on Windows.
> 
> I have tried to load both mod_jk.dll and mod_webapp.so in Apache. mod_jk
> gives me the following error:
> Syntax error on line 195 of c:/programme/wamp/apache/conf/httpd.conf:
> Can't locate API module structure `mod_jk' in file
> c:/programme/wamp/apache/modules/mod_jk.dll: (127) Die angegebene Prozedur
> wurde nicht gefunden:
> 
> The last bit translates to "The specified procedure was not found". The
> relevant lines in my httpd.conf are
> LoadModule mod_jk modules/mod_jk.dll
> AddModule mod_jk.c
> 
> I had more luck with mod_webapp, which loads properly using these lines:
> LoadModule webapp_module modules/mod_webapp.so
> AddModule mod_webapp.c
> WebAppConnection conn      warp  localhost:8008
> 
> But when I add either (or both) of these lines
> WebAppInfo /webapp-info
> WebAppDeploy     examples conn  /examples
> 
> apache -t gives me the following error:
> C:\Programme\Wamp\Apache>apache -t
> Syntax error on line 256 of c:/programme/wamp/apache/conf/httpd.conf:
> Invalid virtual host name
> 
> where in line 256 is either one (or the first of)
> WebAppInfo /webapp-info
> WebAppDeploy     examples conn  /examples
> 
> I have found out that other users had this problem when their ServerName
> directive was commented out in their httpd.conf, and I have tried that
> already, without luck.
> 
> Does anybody have an idea how to solve this problem?
> 
> Thank you very much
> Kristian
> 
> 
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> 



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message