tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Slater <djsla...@bellsouth.net>
Subject Re: Tomcat as NT service going down after 2 months ???
Date Fri, 22 Feb 2002 08:30:19 GMT
Sounds like the symptoms of a VM crash, not Tomcat per se.  The 3.2.3 
box I run, up until a very recent SQL upgrade, used to go down every 
Sunday night in the wee hours.  No logs, or so I thought, until I 
noticed them in the tomcat/bin directory of all places!  You may want to 
look there just in case.  Seems a native call was generating a memory 
exception outside of the VM and the VM was shutting down to protect 
itself, so to speak.  (Specifically it was a close() call on a db 
connection, and something on the SQL side was making the driver go 
wonky, as if the connection was removed from the SQL side but the driver 
was never informed of the fact.)  So, ask them what changed on the SAP 
side too!  Good luck.

Ralphn wrote:
> Hello 
> 
> We have installed Tomcat 3.2.3 on WinNT 4.0 as a service.
> In our webapp we use the jco.jar - a business connector from the sap ag - to connect
to the sap-system.
> 
> since 2 months this runs very well and was never a problem,
> but since monday tomcat just goes down without any logging or what ever.
> sometimes tomcat goes down after just being restarted (??)
> 
> very confusing! our admins say, they haven't changed anything on this system.
> any ideas? 
> log-file too full? 
> 


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message