tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel López Millán <gab...@dif.um.es>
Subject mod_webapp and RedHat 7.2
Date Wed, 13 Feb 2002 17:00:43 GMT
   
    Hi all.

    I have a RedHat 7.2 with:
    libtool-1.4.2
    jakarta-tomcat-4.0.2-src
    jakarta-servletapi-4
    jakarta-ant-1.4.1
    jakarta-tomcat-connectors-4.0.2-src.tar.gz
    Apache-2.0
   
    with jakarta/jakarta-tomcat-connects/webapp/README.txt
    I get:


************************************************************************************
make[1]: Entering directory "apache-2.0"
make[1]: Invoking "make  build"
make[2]: Cambiando a directorio 
`/usr/local/jakarta/jakarta-tomcat-connects/webapp/apache-2.0'
Compiling and Linking Apache 2.0 WebApp Module
/usr/local//apache2/bin/apxs -I../include -c -L ../lib -lwebapp mod_webapp.c
/usr/local/apache2/build/libtool --silent --mode=compile gcc   
-DAP_HAVE_DESIGNATED_INITIALIZER -DLINUX=2 -D_REENTRANT 
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -g -O2 -pthread 
-I/usr/local/apache2/include -I../include  -c -o mod_webapp.lo 
mod_webapp.c && touch mod_webapp.slo
/usr/local/apache2/build/libtool --silent --mode=link gcc -o 
mod_webapp.la -rpath /usr/local/apache2/modules -module -avoid-version 
-I../include  -L../lib -lwebapp  mod_webapp.lo
 
*** Warning: This library needs some functionality provided by -lwebapp.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
 
*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module mod_webapp.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.
make[2]: Saliendo directorio 
`/usr/local/jakarta/jakarta-tomcat-connects/webapp/apache-2.0'
make[1]: Exiting directory "apache-2.0"
make[1]: Saliendo directorio 
`/usr/local/jakarta/jakarta-tomcat-connects/webapp'

*************************************************************************************

I have read some mails of people with the same problem but without answer.
There is any mistake in doc?
There is any doc where apache and tomcat integration is clearly 
explained and updated?

Thanks a lot, Gabi.
   

   




-- 
-------------------------------------------------
Gabriel Lopez Millan - Grupo ANTS-CIRCuS
Facultad de Informática
Universidad de Murcia (España) Tfo: +34 968367645



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message