tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Adams <bad...@AEM-TX.com>
Subject RE: Stupid Tomcat Question (NEWBIE!)
Date Mon, 25 Feb 2002 13:04:31 GMT
this snippet--
BindException:
Address (at that port) is already in use.
Looks like it may be the port where your mod_webapp is running.
check all your ports and that tomcat is configured for and make certain that
there is not something already running.
ports:
8080
8009
8008
I think are some of the default ports use by tomcat.
look in your conf/server.xml file and search through it for the word port.
should be several instances of this usage.
FYI, netstat is the command used to check for port usage (in case you don't
know). 'netstat -a' should give you a full output of all your ports in use
(Bound).
B



--
means that the address is already in use

-----Original Message-----
From: jreid@dpt-ltd.co.uk [mailto:jreid@dpt-ltd.co.uk]
Sent: Monday, February 25, 2002 6:54 AM
To: Tomcat Users List
Subject: RE: Stupid Tomcat Question (NEWBIE!)




Thanks for your words of encouragement.  I've deleted all the files and
restarted the service, and the following appears in catalina.out.  Does it
give
any clues, and what do I do to resolve the problem?

Catalina.start: LifecycleException:  Error creating server socket:
java.net.BindException: Address already in use
LifecycleException:  Error creating server socket:  java.net.BindException:
Address already in use
        at
org.apache.catalina.connector.warp.WarpConnector.initialize(WarpConnector.ja
va)
        at
org.apache.catalina.core.StandardService.initialize(StandardService.java)
        at
org.apache.catalina.core.StandardServer.initialize(StandardServer.java)
        at org.apache.catalina.startup.Catalina.start(Catalina.java)
        at org.apache.catalina.startup.Catalina.execute(Catalina.java)
        at org.apache.catalina.startup.Catalina.process(Catalina.java)
        at java.lang.reflect.Method.invoke(Native Method)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java)
----- Root Cause -----
java.net.BindException: Address already in use
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:452)
        at java.net.ServerSocket.<init>(ServerSocket.java:170)
        at java.net.ServerSocket.<init>(ServerSocket.java:121)
        at
org.apache.catalina.net.DefaultServerSocketFactory.createSocket(DefaultServe
rSocketFactory.java)

        at
org.apache.catalina.connector.warp.WarpConnector.initialize(WarpConnector.ja
va)
        at
org.apache.catalina.core.StandardService.initialize(StandardService.java)
        at
org.apache.catalina.core.StandardServer.initialize(StandardServer.java)
        at org.apache.catalina.startup.Catalina.start(Catalina.java)
        at org.apache.catalina.startup.Catalina.execute(Catalina.java)
        at org.apache.catalina.startup.Catalina.process(Catalina.java)
        at java.lang.reflect.Method.invoke(Native Method)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java)





Brian Adams <badams@AEM-TX.com> on 25/02/2002 12:29:50

Please respond to "Tomcat Users List" <tomcat-user@jakarta.apache.org>

To:   "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
cc:    (bcc: James Reid/DPT-LTD)

Subject:  RE: Stupid Tomcat Question (NEWBIE!)




freaken look at them!
This ain't yo mommas listserve!
delete them all start it once then see what files are generated.
open them and READ!


-----Original Message-----
From: jreid@dpt-ltd.co.uk [mailto:jreid@dpt-ltd.co.uk]
Sent: Monday, February 25, 2002 6:24 AM
To: Tomcat Users List
Subject: RE: Stupid Tomcat Question (NEWBIE!)




The following files all appear under my var/tomcat4/logs directory.  Which
file(s) are of interest.?

catalina_log.2002-01-18.txt
www.dpt-ltd.co.uk_access_log.2002-02-22.txt
catalina_log.2002-02-07.txt
www.dpt-ltd.co.uk_examples_log.2002-01-18.txt
catalina_log.2002-02-13.txt
www.dpt-ltd.co.uk_examples_log.2002-02-07.txt
catalina_log.2002-02-19.txt
www.dpt-ltd.co.uk_examples_log.2002-02-13.txt
catalina_log.2002-02-20.txt
www.dpt-ltd.co.uk_examples_log.2002-02-14.txt
catalina_log.2002-02-21.txt
www.dpt-ltd.co.uk_examples_log.2002-02-15.txt
catalina_log.2002-02-22.txt
www.dpt-ltd.co.uk_examples_log.2002-02-19.txt
catalina_log.2002-02-25.txt
www.dpt-ltd.co.uk_examples_log.2002-02-20.txt
catalina.out
www.dpt-ltd.co.uk_examples_log.2002-02-21.txt
localhost_access_log.2002-01-18.txt
www.dpt-ltd.co.uk_examples_log.2002-02-22.txt
localhost_examples_log.2002-01-18.txt
www.dpt-ltd.co.uk_log.2002-01-18.txt
localhost_log.2002-01-18.txt
www.dpt-ltd.co.uk_log.2002-02-07.txt
www.dpt-ltd.co.uk_access_log.2002-01-18.txt
www.dpt-ltd.co.uk_log.2002-02-13.txt
www.dpt-ltd.co.uk_access_log.2002-02-07.txt
www.dpt-ltd.co.uk_log.2002-02-19.txt
www.dpt-ltd.co.uk_access_log.2002-02-13.txt
www.dpt-ltd.co.uk_log.2002-02-20.txt
www.dpt-ltd.co.uk_access_log.2002-02-19.txt
www.dpt-ltd.co.uk_log.2002-02-21.txt
www.dpt-ltd.co.uk_access_log.2002-02-20.txt
www.dpt-ltd.co.uk_log.2002-02-22.txt
www.dpt-ltd.co.uk_access_log.2002-02-21.txt





Brian Adams <badams@AEM-TX.com> on 25/02/2002 12:21:28

Please respond to "Tomcat Users List" <tomcat-user@jakarta.apache.org>

To:   "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
cc:    (bcc: James Reid/DPT-LTD)

Subject:  RE: Stupid Tomcat Question (NEWBIE!)




Look in the logs directory and tell us what is happening.

-----Original Message-----
From: jreid@dpt-ltd.co.uk [mailto:jreid@dpt-ltd.co.uk]
Sent: Monday, February 25, 2002 6:17 AM
To: tomcat-user@jakarta.apache.org
Subject: Stupid Tomcat Question (NEWBIE!)




Hi,

I've recently downloaded and installed Tomcat 4.0.1 onto my Apache webserver
and
everything seemed to be working ok for a week or so...

However, the problem now is that Tomcat appears to have died on me!  Whenver
I
try to view

http://www.dpt-ltd.co.uk:8180/index.html

then nothing happens.  My  browser just sits there trying to open the page,
but
strangely it never times out.  I've tried stopping and restarting the Tomcat
service several times but it doesn't make any difference.  I've also tried
using
 port 8080 and again it doesn't help.

I know this is a very vague question, but do you have any idea what could be
wrong?  Is there any debugging I could do other than continually restarting
the
service?  Are there any log files I could look at which might help?  It
seems
strange that this worked fine up until recently and as far as I know I've
made
no
changes whatsoever to my Tomcat configuration.

Sorry if this is a dumb question but I'm new to all this.  Please reply
off-list
 if at all possible.

Thanks in advance.



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>








--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>








--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message