tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kris Cheemal <kchee...@yahoo.ca>
Subject Problem accessing session variables - getAttribute returning null
Date Mon, 11 Feb 2002 21:09:10 GMT
Hi Guys,

   I am having a problem with accessing my session
varibles. I am using Tomcat 3.2.3 with JBoss. I have a
servlet heirarchy.

HttpServlet
      |_BasicServlet
	      |_ LoginResultServlet
	      |_ LoginRequiredServlet

I have a public Static fianl String USER_PROFILE =
"userprofile" defined in BasicServlet. 
As soon as I login, I am seeting it in
LoginResultServlet I retrieve the user profile, assign
it to a variable called "userProfile", and putting it
in the session using the method
request.getSession.setAttribute (userProfile,
USER_PROFILE). In LoginRequiredServet, I am using
request.getSession.getAttribute (USER_PROFILE) to
authenticate the user. The problem is that 
getAttribute(USER_PROFILE) is returning null. I did
not have this problem on 3.1. I am just wondering what
the problem is. Any ideas/solutions??

Thanks in advance,
Kris

______________________________________________________________________ 
Web-hosting solutions for home and business! http://website.yahoo.ca

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message