tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert H Clarence <rclare...@juno.com>
Subject Tomcat 4.0.1 setup with servlets..
Date Mon, 11 Feb 2002 20:47:22 GMT
Greetings all,

I am trying to setup Tomcat 4.0.1 to run on a small web site.  I am using
Suse Linux 7.0 .  I am running Tomcat standalone for the moment but I
have encountered a problem attempting to get Tomcat to find my servlets. 
I inserted the following line in the server.xml file

<Context path="/test1" docBase="test1" debug="0" reloadable="true" />

under the Tomcat jakarta-tomcat-4.0.1/webapps directory I have a test1
directory and under that directory I have a WEB-INF directory which
houses my web.xml and classes and lib directories.  My servlet classes
are in the classes sub directory and my web.xml is as follows:

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
    "http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
<servlet>
<servlet-name>T1Servlet</servlet-name>
<servlet-class>com.clarence.web.T1Servlet</servlet-class>
<servlet-mapping>
   <servlet-name>T1Servlet</servlet-name>
   <url-pattern>/T1Servlet</url-pattern>
</servlet-mapping>
<load-on-startup>1</load-on-startup>
</servlet>
</web-app>

Any idea why Tomcat can't find my Servlet????

Thanx

RHC
________________________________________________________________
GET INTERNET ACCESS FROM JUNO!
Juno offers FREE or PREMIUM Internet access for less!
Join Juno today!  For your FREE software, visit:
http://dl.www.juno.com/get/web/.

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message