tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Wadkin <j.wad...@hud.ac.uk>
Subject RE: Servlet POST results in 404 error
Date Tue, 26 Feb 2002 19:43:34 GMT
The servlet is an application that has numerous modes. If I want to create a
new user of the app, I type the URL:

servername/webapp/servletname?mode=19

I enter all the details of the new user, and the servlet "posts" this info -
a get would show password details in the URL. It then creates a page:

servername/webapp/servletname/stringofnumbers

Informing me of the outcome of the attempt to create a new user - i.e.
success or failure. At this point it fails with a 404. The logs give exactly
the same info. I've checked everything I can think of and changed the
DocumentRoot in Apache to the webapps/webappname directory. No joy! As I see
it there are two possibilities:

I've misconfigured TC and/or Apache - but how?
The servlet implements or does something that is no longer supported in
TomCat and/or the latest servlet API.

I'm at a loss!

Thanks,

John


-----Original Message-----
From: Ken Martin [mailto:kenm@digitalcyclone.com]
Sent: 26 February 2002 19:08
To: Tomcat Users List
Subject: Re: Servlet POST results in 404 error


On Tuesday, February 26, 2002, at 12:25 PM, John Wadkin wrote:

> I'd give you the URL but I'd have to give passwords and 
> stuff... It goes
> like this:
>
> servername/webapp/servletname/stringofnumbers

I had some JSP pages that worked on Netscape but not Tomcat. It 
turned out that Tomcat wanted to see a "=" separating the 
name=value pairs. From your example above, it looks like you're 
just trying to pass some numbers so you don't actually need 
the "=" (informationally), but Tomcat does to pass it on through 
the request.

Simply adding the "=" fixed it for me. Now, sometimes I'll add a 
label as the value, like: thedata=a_label, which is a visual 
convenience but ignored by the backend.

Just my experience.

Ken Martin


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message