tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Wadkin <j.wad...@hud.ac.uk>
Subject RE: tomcat 4 + apache 1.3 + WarpConnection
Date Wed, 13 Feb 2002 11:25:15 GMT
AFAIK, in TomCat 4, every engine needs at least one host. Set engine's
"defaultHost" attribute to match the "name" attribute of the host element. I
assume that earlier versions of TomCat will follow the same logic. Have a
read of the TomCat documentation on the engine and host elements.
 
John
 

-----Original Message-----
From: Domenico Piol [mailto:domenico.piol@infometis.ch]
Sent: 12 February 2002 08:29
To: tomcat-user
Subject: RE: tomcat 4 + apache 1.3 + WarpConnection


well, on my opinion i would need that when i would use virtual hosts, but
i don't.... is my opinion wrong ?

> Your server.xml needs a host - something like this:
>
> Server port="8005" shutdown="SHUTDOWN" debug="0">
>
>  <Service name="Tomcat-Apache">
>
>    <Connector
>    className="org.apache.catalina.connector.warp.WarpConnector"
>     port="8008" minProcessors="5" maxProcessors="75"
>     enableLookups="true"
>     acceptCount="10" debug="0"/>
>
>    <Engine className="org.apache.catalina.connector.warp.WarpEngine"
>     name="Apache" defaultHost="myserver.domain.com" debug="0"
> appBase="webapps">
>
>      <!-- Define the default virtual host -->
>      <Host name="myserver.domain.com" debug="0" appBase="webapps"
> unpackWARs="true">
>
>
>        <Valve className="org.apache.catalina.valves.AccessLogValve"
>                 directory="logs"  prefix="localhost_access_log."
> suffix=".txt"
>                 pattern="common"/>
>
>        <Logger className="org.apache.catalina.logger.FileLogger"
>                 directory="logs"  prefix="apache_log." suffix=".txt"
> 	        timestamp="true"/>
>
>        <!-- Tomcat Manager Context -->
>        <Context path="/manager" docBase="manager"
>         debug="0" privileged="true"/>
>
>      </Host>
>
>      <!-- Because this Realm is here, an instance will be shared
>      globally
> -->
>      <Realm className="org.apache.catalina.realm.MemoryRealm" />
>
>    </Engine>
>
>  </Service>
>
> </Server>
>
> Don't know if it'll help!
>
> John
>
>
> -----Original Message-----
> From: Domenico Piol [mailto:domenico.piol@infometis.ch]
> Sent: 11 February 2002 09:14
> To: tomcat-user
> Subject: tomcat 4 + apache 1.3 + WarpConnection
>
>
> hi
> i'm trying to get my tomcat installation work together with apache
> 1.3... without success. tomcat works fine as standalone, but with
> WarpConnection i get an error:
>
> *** error
> ****************************************************************
> 2002-02-11 08:51:53 [org.apache.catalina.connector.warp.WarpConnection]
> Exception on socket
> java.io.IOException: Premature packet header end
>        at
>        org.apache.catalina.connector.warp.WarpConnection.recv(Unknown
> Source)
>        at org.apache.catalina.connector.warp.WarpRequestHandler.handle
> (Unknown Source)
>        at org.apache.catalina.connector.warp.WarpConnection.run(Unknown
> Source)
>        at java.lang.Thread.run(Thread.java:484)
>
> 2002-02-11 08:51:54 [org.apache.catalina.connector.warp.WarpConnector]
> Connection from localhost/127.0.0.1:2394 to localhost/127.0.0.1:8008
> 2002-02-11 08:51:54
> [org.apache.catalina.connector.warp.WarpConfigurationHandler] Filter
> mappings (2)
> 2002-02-11 08:51:54
> [org.apache.catalina.connector.warp.WarpConfigurationHandler] Filter
> mappings (0)
>
***************************************************************************
>
> i don't use a virtual host in my apache config, is that the problem ?
> my configs look as follwows:
>
> *** server.xml
> *********************************************************** <!-- Define
> an Apache-Connector Service -->
>  <Service name="Tomcat-Apache">
>
>    <Connector
>    className="org.apache.catalina.connector.warp.WarpConnector"
>     port="8008" minProcessors="5" maxProcessors="75"
>     enableLookups="false" appBase="webapps"
>     acceptCount="10" debug="0"/>
>
>    <!-- Replace "localhost" with what your Apache "ServerName" is set
>    to -
> ->
>    <Engine className="org.apache.catalina.connector.warp.WarpEngine"
>     name="arakis" debug="0">
>
>      <!-- Global logger unless overridden at lower levels -->
>      <Logger className="org.apache.catalina.logger.FileLogger"
>              prefix="apache_log." suffix=".txt"
>              timestamp="true"/>
>
>      <!-- Because this Realm is here, an instance will be shared
> globally -->
>      <Realm className="org.apache.catalina.realm.MemoryRealm" />
>
>    </Engine>
>
>  </Service>
>
**************************************************************************
>
> *** httpd.conf
> *********************************************************** ...
> ServerName arakis.local
> ...
> LoadModule webapp_module      /usr/lib/apache/mod_webapp.so
> AddModule mod_webapp.c
> ...
> DocumentRoot "/usr/local/httpd/htdocs"
>
> ### NOT in a virtual host ####
> WebAppConnection        conn            warp    localhost:8008
> WebAppDeploy            webdav          conn    /webdav
> WebAppDeploy            examples        conn    /examples
>
> WebAppInfo      /webapp-info
> ...
>
**************************************************************************
>
> tomcat runs as user wwwrun, as well as apache.
>
> i'm thankfull for any hint...
>
> domenico
> -----------------------------------------------------------
> domenico piol                                  infometis ag
> eidg. dipl.                                    zuerich
> wirtschaftsinformatiker                        switzerland
>
> email: domenico.piol@infometis.ch
> www:   http://www.infometis.ch/users/dpiol/
> -----------------------------------------------------------

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message