tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Satoshi Okamoto" <satoshi.okam...@mizuho-sc.com>
Subject tomcat4.0.2+apache1.3.23+mod_webapp.so went well but why?
Date Mon, 18 Feb 2002 06:48:41 GMT
below is configurations of server.xml of tomcat 4.0.2 and httpd.conf of
apache 1.3.23 (most parts were cut, only the part that i modified is shown).
first of all, http://tecdev15:8005 works fine. and http://tecdev15:8080
works fine, too. but why does both 8005 and 8080 work? i guessed 8080 works
only as tomcat, not with apache, and 8005 works as a combination of tomcat
and apache. correct me if im wrong.

also port 7005 as shown on httpd.conf is doing nothing.(i meant
http://tecdev15:7005)
WebAppConnection is pointing tecdev15:7005 so this should be working as a
combination of apache and tomcat, rather than port 8005.

i do not even know if this is the correct configuration of both server,xml
and httpd.conf ( and im pretty new to use apache)
any information or help would be appreciated

thanks!



######## server.xml ################
<!--  Define a non-SSL HTTP/1.1 Connector on port 8080
  -->
  <Connector className="org.apache.catalina.connector.http.HttpConnector"
port="8080" minProcessors="5" maxProcessors="75" enableLookups="true"
redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="60000" />
- <!--
 Note : To disable connection timeouts, set connectionTimeout value
     to -1

  -->
- <!--  Define an SSL HTTP/1.1 Connector on port 8443
  -->
- <!--
    <Connector className="org.apache.catalina.connector.http.HttpConnector"
               port="8443" minProcessors="5" maxProcessors="75"
               enableLookups="true"
	       acceptCount="10" debug="0" scheme="https" secure="true">
      <Factory className="org.apache.catalina.net.SSLServerSocketFactory"
               clientAuth="false" protocol="TLS"/>
    </Connector>
  -->

############ httpd.conf #################
# Port: The port to which the standalone server listens. For
# ports < 1023, you will need httpd to be run as root initially.
Port 8005
ServerName tecdev15
#LoadModule webapp_module libexec/mod_webapp.so
WebAppConnection warpConnection warp tecdev15:7005
WebAppDeploy examples warpConnection /examples
WebAppDeploy okamoto warpConnection /okamoto
WebAppConnection _INFO_ info
WebAppDeploy _INFO_ _INFO_ /info




--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message