tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jeff.guttada...@abbott.com
Subject Re: Problems with GET method
Date Mon, 14 Jan 2002 18:37:54 GMT

Hi, Luiz.

     I think the equals sign in the parameter value needs to be escaped.  Take
a look at the java.net.URLEncoder class to help with that.

HTH,
-Jeff



                                                                                         
                          
                    "Luiz Ricardo"                                                       
                          
                    <luizricardo@i        To:     <tomcat-user@jakarta.apache.org>
                                 
                    tx.com.br>            cc:                                         
                             
                                          Subject:     Problems with GET method          
                          
                    01/14/02 12:33                                                       
                          
                    PM                                                                   
                          
                    Please respond                                                       
                          
                    to "Tomcat                                                           
                          
                    Users List"                                                          
                          
                                                                                         
                          
                                                                                         
                          




Hi,

I am trying to pass some parameters to my app by URL but when I try to get
them I always get the null value when the parameter value contains the equal
sign (=).

If I try process the following URL
www.server.com/page.jsp?var1=where+col=val and use
request.getParameter("var1"), it returns null.

I would like to know if someone has faced this problem and/or has some
solution?!

Luiz Ricardo


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>






--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message