tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pavel Brun" <pavel.b...@sympatico.ca>
Subject RE: JasperLoader Exception
Date Fri, 01 Feb 2002 01:04:20 GMT
Unfortunately, even changing to an object that is created every time the
page
is accessed still gives me the same result. I get a NullPointerException in
the ClassLoader the first time I access this particular page after starting
the
Tomcat service, yet on each subsequent access (even after a session times
out),
the page loads up without any problems (even with a new browser window)...

This will forever puzzle me because it is something I can't really prove to
you unless I start the service and one of you accesses it for the first
time.

Any suggestions???

Paul


-----Original Message-----
From: Pavel Brun [mailto:pavel.brun@sympatico.ca]
Sent: Thursday, January 31, 2002 12:13 PM
To: Tomcat Users List
Subject: RE: JasperLoader Exception


Well....there is only one problem this....since I am creating a Singleton
object...it exists for all of time. As a result....nobody will see it after
the first time the page is ever accessed. I will try to change this, so the
object is create every time the page is accesed.

Thanks

Paul

-----Original Message-----
From: Pavel Brun [mailto:pavel.brun@sympatico.ca]
Sent: Thursday, January 31, 2002 8:12 AM
To: Tomcat Users List
Subject: RE: JasperLoader Exception


sure....I will set up a test case....I will have something up by about noon
time or so...and I will post a download of the java source code, JSP file
within a ZIP File as well....

Thanks

Paul

-----Original Message-----
From: Remy Maucherat [mailto:remm@apache.org]
Sent: Thursday, January 31, 2002 5:36 AM
To: Tomcat Users List
Subject: Re: JasperLoader Exception


> Thanks for your reply...but could this be the problem that is related to
> the Jasper ClassLoader Exception error I am getting when first accessing
> this page. After I refresh the page (this is after the Singleton instance
> of my object is created), the page loads up without any problems...
>
> Could this be related to a Security Manager (or lack of) within the
context
> of this application?

And how about sending a test case ?

Remy


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>




--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message