tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin van den Bemt" <mar...@isallineed.org>
Subject RE: basic servlet move doesn't work
Date Mon, 21 Jan 2002 15:54:59 GMT
Is dir your package name and is the servlet in the webapp or in a jar (read
something about tc4 not recognizing servlets in jars outside of the webapp)

Mvgr,
Martin

> -----Original Message-----
> From: Cressatti, Dominique [mailto:Dominique.Cressatti@lansa.co.uk]
> Sent: Monday, January 21, 2002 16:53
> To: Tomcat Users List
> Subject: basic servlet move doesn't work
>
>
> Hi,
>
> I have a very simple example app.
> For testing purposes I moved the servlet into a subdirectory.
> So before the move I had
> /webapps/Wide_World/WEB-INFO/classes/ForwardServlet.class
> and after the move I had
> /webapps/Wide_World/WEB-INFO/classes/dir/ForwardServlet.class
>
> according to the docs I've read I can do such a thing and reflect it
> I need edit /webapps/Wide_World/web.xml
>
> from:
> ....<servlet-name>forward</servlet-name>
>     <servlet-class>ForwardServlet</servlet-class>
>
> to
> ....<servlet-name>forward</servlet-name>
>     <servlet-class>dir.ForwardServlet</servlet-class>
>
> which I did (and restated tomcat).
> However how such simple change doesn't work?
> Now when I try to access again the servlet I get:
> ...HTTP error status 500...
> Error allocating a servlet instance....
> root cause
> java.lang.NoClassDefFoundError: dir/ForwardServlet (wrong name:
> ForwardServlet)...
>
> What's going on!
>
> Thanks
> Dom
>
>
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message