tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin van den Bemt" <mar...@isallineed.org>
Subject RE: Mod_webApp Configuration - Tomcat 4.01, Apache 1.3.22 (Darwin)
Date Mon, 21 Jan 2002 08:45:31 GMT
>From your message I assume that you didn't get any errors when starting up
apache. Since your html attachments was left out of the post, I cannot see
if your webapps are deployed or not. (according to webapp info). The minimum
I can suggest is to use the version of mod_webapp from cvs (which I do),
which contains some fixes regarding automatic deployment of webapps when
they are not available at startup of apache (the order of starting httpd and
tomcat is not important anymore). In the "old" webapp you have to start
tomcat before apache to get requests through.

Mvgr,
Martin

> -----Original Message-----
> From: Terry J Fundak [mailto:terry@tjsoftworks.com]
> Sent: Sunday, January 20, 2002 08:54
> To: Tomcat User List
> Subject: Mod_webApp Configuration - Tomcat 4.01, Apache 1.3.22 (Darwin)
>
>
> After a couple of weeks of really struggling with this, I need to ask
> some really basic questions:
>
> Tomcat standalone configuration is EZ, quick and works perfectly the
> first time...
>
> Using mod_webapp is a real mystery...and I'm ready to get up? I really
> have tried a lot of things with little progress of getting the setup
> correct.
>
> I have attached the output from WebApp-info which is the only thing that
> I have gotten to respond with any information...Sorry it is HTML because
> that is what webapp-info gives...
>
> So My Question is:
>
> Where is mod_webapp supposed to get the "Local Deployment Path"?
>     And if it isn't right where do I set it?
> And if mod_webapp is NOT looking in the server.xml file in my
> $JAKARTA_HOME/config/ directory, where is it looking or how do I set it
> to look elsewhere?
>
> Before someone says: Read the documentation, PLEASE I HAVE! I have read
> and searched literally for days on the web. I have tried the FAQ at the
> JAKARTA project which send you to the "documentation" which is
> incomplete. I have read 100's and 100's of posts to this group. I tried
> to read the FAQ, which do not yet exist apparently. So I know I'm not
> completely crazy when I ask these questions.
>
> And for completeness, here is my httpd.conf for a simple localhost.
>
> ...
>                                          LoadModule webapp_module
> libexec/httpd/mod_webapp.so
> ...
>                                          AddModule mod_webapp.c
> ....
>
>                                          WebAppConnection tomcat4 warp
> localhost:8008
>                                          <IfModule mod_webapp.c>
>                                              WebAppDeploy examples
> tomcat4_connect /warp_examples
>                                              WebAppDeploy cocoon
> tomcat4_connect /warp_cocoon
>                                              WebAppDeploy henry
> tomcat4_connect /henry
>                                              WebAppInfo /webapp-info
>                                          </IfModule>
>
> At this point, I need someone who has succeeded to tell me EXACTLY what
> they have done.
>
> Thank you,
>
> Terry J Fundak
>
> P.S. If I get this working I will write up detailed directions and a lot
> of notes about what not to do. This is what the FAQ's for TOMCAT 4.0 and
> mod_webapp needs at this point.
>
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message