tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Adams" <b...@satx.rr.com>
Subject RE: Help !!! JNI & Tomcat (UnSatisfiedLinkError exception)
Date Thu, 31 Jan 2002 02:31:14 GMT
Tomcat must not look in the \winnt\system32 directory.
put the dll in the same directory as the class file.
If you have tomcat starting as a service, try putting the dll in the
%TOMCAT_HOME% directory eg. C:\tomcat
lastly try putting the dll in %TOMCAT_HOME%\bin directory.
goodluck,
B

-----Original Message-----
From: Anil Bhagwat [mailto:anilb_dev@hotmail.com]
Sent: Wednesday, January 30, 2002 4:35 PM
To: tomcat-user@jakarta.apache.org
Subject: Help !!! JNI & Tomcat (UnSatisfiedLinkError exception)


Hi,

I have been trying to use JNI on Win2K using tomcat 4.0. I am running into a
problem.

I keep getting UnSatisfiedLinkError exception. This doesn't happen when I
execute the JNI from a sample JAVA application. I have placed the DLL under
\winnt\system32 directory. The DLL is a C++ COM DLL compiled using MS Visual
C++ 6.0. I tried using a C++ (no COM) DLL and a C DLL but no success.

I tried creating just a simple function that doesn't accept any parameters &
doesn't return any value. But, still it doesn't work. So, the problem is
unlikely to have with the param types etc.

I tried this on several versions of Tomcat but no success. I think the app
finds the DLL correctly but can't find the method within correctly. I
suspect this has something to do with Tomcat configuration (security ??).

Has anyone seen this problem before ? While browsing thru' archives, I saw
quite few people have run into this issue, but didn't notice any resolution.
I would appreciate any help on this issue.

thanks

- Anil

_________________________________________________________________
Join the worldÂ’s largest e-mail service with MSN Hotmail.
http://www.hotmail.com


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message