tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ion LarraƱaga <ila...@s21sec.com>
Subject RE: INSTALLING Tomcat-4.0 with JDK1.4 beta.
Date Fri, 18 Jan 2002 17:09:56 GMT

When JDK1.4 beta3 is installed the following values are not included in the
registry:

Under "HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development Kit" you must
create value "CurrentVersion" as "1.4".

The same value must be included under
"HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Runtime Environment".

These values are used by the Tomcat installation to detect the base Java
directory (instead of using JAVA_HOME, which would be the best option).

Note that these values point to other keys in the registry, which must also
exist. This is,
"HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development Kit/1.4" and
"HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Runtime Environment/1.4".

Still, I think I heard something about newer Tomcat installation programs
that solve this problem (I guess by using JAVA_HOME).

Hope it helps,

  Ion


-----Mensaje original-----
De: Brian Adams [mailto:badams@AEM-TX.com]
Enviado el: viernes, 18 de enero de 2002 16:27
Para: 'Tomcat Users List'
Asunto: RE: INSTALLING Tomcat-4.0 with JDK1.4 beta.


It does work I am using it.  There is a registry error that causes that.  I
don't know how to fix the registry but others here do.
I download the src version for windows and installed by hand and it works
great on two machines! :)
ohh, you did not say what OS, I assumed Windows if not dunno..

-----Original Message-----
From: JavaWriter2002@netscape.net [mailto:JavaWriter2002@netscape.net]
Sent: Friday, January 18, 2002 9:39 AM
To: tomcat-user@jakarta.apache.org
Subject: INSTALLING Tomcat-4.0 with JDK1.4 beta.



Yes you guessed it...Tomcat4.0 won't install using jdk1.4 beta.  The first
thing it does is says it cant find a Java Development kit.  Works fine with
JDK1.3 so I'm guessing jdk1.4 will install once it is out of beta.  Correct?
There are some new utilities in jdk1.4 I'd like to use, but I've noticed
other things that don't work in jdk1.4 that traditionally works in the rest,
namely the way a class is imported.

PM
--




__________________________________________________________________
Your favorite stores, helpful shopping tools and great gift ideas.
Experience the convenience of buying online with Shop@Netscape!
http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at
http://webmail.netscape.com/


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message